Older pkg-config versions cannot build packages like xdm and xlogo

Alan Coopersmith Alan.Coopersmith at Sun.COM
Thu Sep 29 11:25:33 PDT 2005

Shawn Starr wrote:
> The pkg.m4 macros in newer versions of pkgconfig
> contain macros that are not present in the minimal
> version of 0.9.0.
> Can we bump this up to a more recent version? I
> noticed this because one of my machines had pkgconfig
> 0.15.0 which broke xdm and xlogo.

As mentioned on IRC, the "0.9.0" is the default minimum version
from pkg.m4, which we haven't overridden.   As far as I know,
for someone building the packages we'll distribute with pre-generated
configure scripts that should be good enough - it's only people
regenerating configure scripts who need the new versions to get
the updated pkg.m4 macro definitions.

It does look like we could require something newer with
PKG_PROG_PKG_CONFIG([MIN-VERSION]), but we haven't explicitly set
that ourselves yet.

	-Alan Coopersmith-           alan.coopersmith at sun.com
	 Sun Microsystems, Inc. - X Window System Engineering

More information about the xorg mailing list