Trying to use Radeon driver on Apple eMac

Alex Deucher alexdeucher at
Tue Dec 9 08:12:32 PST 2008

On Tue, Dec 9, 2008 at 7:39 AM, Joseph Adams <joeyadams3.14159 at> wrote:
> I wrote a little script and got the Xorg.0.log of every combination.
> In some of the tests, I heard Fedora 10 GNOME's startup sound, and
> other times I didn't.  IIRC the snippet posted farther down is from a
> test where I heard the startup sound.  I also got my dmesg (after
> rebooting) which may contain some useful information:

Logs look good.  We'll have to do more testing when you get an
external monitor in order to determine the ddc line used for the
external port.  For now it looks like the monitor doesn't like the
default mode the xserver is choosing:

(II) RADEON(0): Printing probed modes for output VGA-1
(II) RADEON(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800
960 961 964 1000 +hsync +vsync (60.0 kHz)
(II) RADEON(0): Modeline "1280x960"x59.9  101.25  1280 1360 1488 1696
960 963 967 996 -hsync +vsync (59.7 kHz)
(II) RADEON(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344
768 771 777 806 -hsync -vsync (48.4 kHz)
(II) RADEON(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600
601 605 628 +hsync +vsync (37.9 kHz)
(II) RADEON(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480
490 492 525 -hsync -vsync (31.5 kHz)
(II) RADEON(0): Output: VGA-0, Detected Monitor Type: 0
(II) RADEON(0): EDID for output VGA-0
(II) RADEON(0): Output VGA-1 connected
(II) RADEON(0): Output VGA-0 disconnected
(II) RADEON(0): Using user preference for initial modes
(II) RADEON(0): Output VGA-1 using initial mode 1280x960

Does it work if you switch to a different mode with xrandr, e.g.,
xrandr --output VGA-1 --mode 1024x768

or adding your mode:
xrandr --newmode  "1024x768j" 99.198 1024 1072 1168 1376 768 769 772
810 +HSync +VSync
xrandr --addmode VGA-1 1024x768j
xrandr --output VGA-1 --mode 1024x768j

When we find a mode you want to use you can make it your preferred
mode in your xorg.conf.  Make sure to set your monitor Identifier to
"VGA-1" or associate it with whatever your monitor section is called
Option "Monitor-VGA-1" "my monitor name".  see this page for more info
on xrandr config:

Make sure you test with one of the ConnectorTable options I suggested.


More information about the xorg mailing list