[PATCH] evdev: Array sizes and iterations off by one
matt.helsley at gmail.com
Sun Jan 11 17:53:05 PST 2009
On Mon, 2009-01-12 at 10:42 +1000, Peter Hutterer wrote:
> On Sat, Jan 10, 2009 at 11:05:12PM -0800, Matt Helsley wrote:
> > ABS_CNT (and friends) need to be used in some places instead of
> > ABS_MAX. Also "NBITS" seems misnamed -- it is really the number of
> > longs needed to hold the specified number of bits.
> Thanks for the patch. Please split it up into two separate one though, one the
> NBITS rename, one the ABS_CNT patch, and I'll push it.
> (Also, while we're changing the NBITS to NLONGS, please add a one-line comment to
> NLONGS to explain what it's supposed to do.)
OK, makes sense.
More information about the xorg