XORG_MACROS_VERSION test is filled with hate

Dan Nicholson dbn.lists at gmail.com
Tue Jan 20 11:36:08 PST 2009

On Tue, Jan 20, 2009 at 11:28 AM, Ian Romanick <idr at freedesktop.org> wrote:
> I think these lines, when added to configure.ac don't do what they're
> intended to do:
> m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2
> or later before running autoconf/autogen])])

One thing is that the AC_FATAL should probably be m4_fatal so that it
bombs when aclocal runs, not when the user runs ./configure. But
that's besides the point here.

> I run autogen.sh in, for example, app/rendercheck as:
> CC=gcc ACLOCAL="aclocal -I /opt/xorg-master-x86_64/share/aclocal"
> sh ./autogen.sh --prefix=/opt/xorg-master-x86_64
> --libdir=/opt/xorg-master-x86_64/lib64 --disable-dmx --disable-xvfb
> --disable-xnest --disable-xwin --disable-xgl --disable-xglx
> --disable-xegl --disable-kdrive --disable-xprint --enable-glx
> --enable-glx-tls --enable-dri CFLAGS="-momit-leaf-frame-pointer
> -march=core2"
> The xorg-macros.m4 in /opt/xorg-master-x86_64/share/aclocal is version
> 1.2.1:
> [idr at oscar rendercheck]$ grep
> 1.2. /opt/xorg-master-x86_64/share/aclocal/xorg-macros.m4
>        [XORG_MACROS_version=1.2.1
> # Minimum version: 1.2.0
> # Minimum version: 1.2.0
> But I get the error message:
> checking if xorg-macros used to generate configure is at least 1.2...
> configure: error: configure built with too old of a version of
> xorg-macros.m4 - requires version 1.1.0 or newer

Are you running this from a clean checkout? It would seem that the
version of XORG_MACROS_VERSION in aclocal.m4 (what actually gets into
configure) is an older version. XORG_MACROS_VERSION seems to work for


More information about the xorg mailing list