Auto-repeat with evdev 2.2.0

Peter Hutterer peter.hutterer at
Mon Mar 9 19:57:48 PDT 2009

On Mon, Mar 09, 2009 at 10:15:50PM -0400, Marty Jack wrote:
> Dropping evdev 2.2.0 onto a system that was running 2.1.3 caused auto-repeat to stop working.
> The keyboard is a run of the mill keyboard connected via a PS/2 connector.  HAL is not installed.
> Restoring 2.1.3 restored auto-repeat.  xset q reported the same auto-repeat settings under both drivers.
> Anyone else experience this?  Regression or something changed in what configuration is needed?
> If it might be a configuration problem, what should I be looking at?

That's probably a result of 
commit ece72ce9e97adae23b1932dc1334f63669196d56
Author:     Sascha Hlusiak <saschahlusiak at>
AuthorDate: Mon Dec 8 12:27:34 2008 +0100

Filter all repeated keys from kernel, because we do softrepeat in server

Discard all repeated events that come from the device. The server will handle
per-key autorepeat in software.

and you need the following xserver commit 
commit bbf811514d3cdf84790bad5b852942a4e636902b
Author:     Sascha Hlusiak <saschahlusiak at>
AuthorDate: Mon Dec 8 12:24:39 2008 +0100

ddxCtrls.c: XkbDDXUsesSoftRepeat always returns 1 now

We'd like to do soft repeat in the server for all keys. Remove obscure check,
that'd prevent the server from autorepeating when delay is set to exactly
660ms and rate is set to exactly 25 (interval=40).
(ff9b55d8cbc19e0e31a91034e332058acd967cd1 in the 1.6 branch)

What server version are you running? 1.5?


More information about the xorg mailing list