Mouse issues with Dual Head setup

James Shewey jdshewey at
Tue May 19 13:12:04 PDT 2009

I have a dual head setup on Kubuntu 9.04 (which means I am using 1.6) and I
can't seem to type on the second head. I have KDE running on 1 screen, but
am not running a window manager on the other screen - Only a virtualbox VM.
I CAN move my mouse between screens and manage windows using it, however, I
cannot get keyboard input to switch to this screen. It just keeps typing in
the last selected window on display :0.0. Is I am running the following
script at startup:

jshewey at jimmylinux:~$ cat /home/jshewey/.kde/Autostart/compiz

compiz.real --replace --ignore-desktop-hints --only-current-screen &
DISPLAY=":0.1" VBoxManage startvm 'Windows XP' -type gui

I did however try disabling compiz on both monitors to make sure this wasn't
influencing the situation and found that I still could not type in the VM. I
also tried starting an xterm window on display :0.1 using the command
DISPLAY=":0.1" xterm and still cound not type on that monitor, so the issue
is not specific to the VM.

This is my current xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd at palmer)  Sun Feb  1 20:21:04 UTC

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 1024
    Screen      1  "Screen1" Above "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Module"
    Load           "dbe"
    Load           "extmod"
#    Load           "type1"
#    Load           "freetype"
    Load           "glx"

Section "ServerFlags"
    Option         "Xinerama" "0"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "Monitor"
    Identifier     "Configured Monitor"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"

Thanks for your suggestions
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list