Not able to get the display , mouse and keyboard aftre compiling Xorg6.7.0 from sources.

suganthan suganthan at
Tue Sep 22 23:26:23 PDT 2009

      I am trying to compile X11R6.7.0 on *MPC8641D* which has
* linux kernel 2.6.22 *running on it.

I have installed PMC706 ( *ATI RADEON MOBILITY M9*) on to a Curtiss 
Wrights* CW184  SBC*, through PMC slot.

I am using a *native ppc toolchain of PPC 74xx* to *compile X sources*.

When i compiled the sources with freetype , fontconfig, the compilation 
throwed error at these stages saying Dwarf error.

So , i disabled fontconfig,freetype, expat, zlib, Xt in the host .def file.

Then the compilation went threw, and i got the X binaries.

I did xorgcfg to generate the the X config file &  i started running the
X using the config file that is generated.

When i see the process status  it says,

X as running.

But the problem here is
i could not see the keyboard and mouse working.
There is also no display.
I was not able to run any X application like xterm, xclock etc.

When i run xrandr -q , i am not getting any results.

When i opened the *Xorg.0.log*, it said

*(WW )Video BIOS not detected in PCI space!

I am not able to gauge what could be the problem.

I kindly request ppl to throw some lights on this issue.

I had also attached the xorg.conf and the Xorg.0.log file


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xorg.conf
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 21420 bytes
Desc: not available
URL: <>

More information about the xorg mailing list