[PATCH] dri2: Fix order of operations issue in __glXdriSwapEvent test.

Keith Packard keithp at keithp.com
Sun Jan 24 12:49:00 PST 2010


On Thu, 21 Jan 2010 10:31:04 -0800, Eric Anholt <eric at anholt.net> wrote:

> -    if (!drawable->eventMask & GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK)
> +    if (!(drawable->eventMask & GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK))

Reviewed-by: Keith Packard <keithp at keithp.com>

I'll note that using 'drawable' as a name here is sub-optimal. Also the
code in glxcmds.c that sets eventMask has an inaccurate comment, and
also fails to validate the event mask to make sure it doesn't include
bits which aren't allowed.

-- 
keith.packard at intel.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20100124/28aeb826/attachment.pgp>


More information about the xorg mailing list