[PATCH] dri2: Fix order of operations issue in __glXdriSwapEvent test.

Jesse Barnes jbarnes at virtuousgeek.org
Mon Jan 25 12:45:49 PST 2010


On Sun, 24 Jan 2010 12:49:00 -0800
Keith Packard <keithp at keithp.com> wrote:

> On Thu, 21 Jan 2010 10:31:04 -0800, Eric Anholt <eric at anholt.net>
> wrote:
> 
> > -    if (!drawable->eventMask & GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK)
> > +    if (!(drawable->eventMask &
> > GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK))
> 
> Reviewed-by: Keith Packard <keithp at keithp.com>
> 
> I'll note that using 'drawable' as a name here is sub-optimal. Also
> the code in glxcmds.c that sets eventMask has an inaccurate comment,
> and also fails to validate the event mask to make sure it doesn't
> include bits which aren't allowed.

Oops yeah thanks for catching it.  This might actually explain the kwin
crash I hit after fixing a bug with drawable lifetimes...

-- 
Jesse Barnes, Intel Open Source Technology Center



More information about the xorg mailing list