merge the AMDGPU_FAMILY_* and AMD_FAMILY_*
alexdeucher at gmail.com
Wed Jul 6 14:09:41 UTC 2016
On Wed, Jul 6, 2016 at 9:55 AM, StDenis, Tom <Tom.StDenis at amd.com> wrote:
> While trying to dive into powerplay I've noticed there are AMD_FAMILY_*
> (powerplay) and AMDGPU_FAMILY_* (amdgpu) defines. They should be merged or
> at the very least the powerplay ones should be defined after them e.g.
> #define AMD_FAMILY_CZ AMDGPU_FAMILY_CZ
> I'd rather just unify them if there are no objections.
The ones in amd_shared.h were originally used internally in the
driver, later we exposed it to userspace and added them to
amdgpu_drm.h. Seems like a good idea to clean these up.
> amd-gfx mailing list
> amd-gfx at lists.freedesktop.org
More information about the amd-gfx