[PATCH 0/8] Part I: introduce the dependences of iceland powerplay support
Huang Rui
ray.huang at amd.com
Fri Jul 15 05:20:19 UTC 2016
Hi all,
This patch set introduces the dependences of iceland powerplay
support. They add some helper functions, macro definitions and rename
amdgpu smc part. And I will submit the functionality support at Part
II in following days.
Thanks,
Rui
Huang Rui (8):
drm/amdgpu: rename smumgr to smum for dpm
drm/amdgpu: no need load microcode at sdma if powerplay is enabled
drm/amdgpu: add ucode_start_address into cgs_firmware_info
drm/amd/powerplay: add SMU register macro for future use
drm/amdgpu: add new definitions into ppsmc.h for iceland
drm/amd/powerplay: add atomctrl_get_voltage_evv function in ppatomctrl
drm/amd/powerplay: fix the incorrect return value
drm/amd/powerplay: add pp_tables_get_response_times function in
process pptables
drivers/gpu/drm/amd/amdgpu/amdgpu_cgs.c | 4 ++
drivers/gpu/drm/amd/amdgpu/iceland_dpm.c | 2 +-
drivers/gpu/drm/amd/amdgpu/iceland_smc.c | 2 +-
drivers/gpu/drm/amd/amdgpu/iceland_smum.h | 41 ++++++++++++++++++
drivers/gpu/drm/amd/amdgpu/iceland_smumgr.h | 41 ------------------
drivers/gpu/drm/amd/amdgpu/ppsmc.h | 4 ++
drivers/gpu/drm/amd/amdgpu/sdma_v2_4.c | 28 ++++++------
drivers/gpu/drm/amd/include/cgs_common.h | 4 ++
drivers/gpu/drm/amd/powerplay/hwmgr/ppatomctrl.c | 50 +++++++++++++++++++++-
drivers/gpu/drm/amd/powerplay/hwmgr/ppatomctrl.h | 1 +
.../gpu/drm/amd/powerplay/hwmgr/processpptables.c | 13 ++++++
.../gpu/drm/amd/powerplay/hwmgr/processpptables.h | 17 +++++---
drivers/gpu/drm/amd/powerplay/inc/smumgr.h | 29 +++++++++++++
13 files changed, 171 insertions(+), 65 deletions(-)
create mode 100644 drivers/gpu/drm/amd/amdgpu/iceland_smum.h
delete mode 100644 drivers/gpu/drm/amd/amdgpu/iceland_smumgr.h
--
2.7.4
More information about the amd-gfx
mailing list