[PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap

Jochen Rollwagen joro-2013 at t-online.de
Fri Nov 4 08:23:09 UTC 2016


 From ba45efaafc3cf790c44b905d2f6272ef7830b403 Mon Sep 17 00:00:00 2001
From: Jochen Rollwagen <joro-2013 at t-online.de>
Date: Fri, 4 Nov 2016 08:39:30 +0100
Subject: [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap

RadeonCopySwap is never called with swap=RADEON_HOST_DATA_SWAP_HDW. 
Remove the case from the switch for clarity.
---
  src/radeon_accel.c |   10 ----------
  1 file changed, 10 deletions(-)

diff --git a/src/radeon_accel.c b/src/radeon_accel.c
index 1def2a3..af2fc99 100644
--- a/src/radeon_accel.c
+++ b/src/radeon_accel.c
@@ -131,16 +131,6 @@ int radeon_cs_space_remaining(ScrnInfoPtr pScrn)
  void RADEONCopySwap(uint8_t *dst, uint8_t *src, unsigned int size, int 
swap)
  {
      switch(swap) {
-    case RADEON_HOST_DATA_SWAP_HDW:
-        {
-        unsigned int *d = (unsigned int *)dst;
-        unsigned int *s = (unsigned int *)src;
-        unsigned int nwords = size >> 2;
-
-        for (; nwords > 0; --nwords, ++d, ++s)
-        *d = ((*s & 0xffff) << 16) | ((*s >> 16) & 0xffff);
-        return;
-        }
      case RADEON_HOST_DATA_SWAP_32BIT:
          {
          unsigned int *d = (unsigned int *)dst;
-- 
1.7.9.5


-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Remove-RADEON_HOST_DATA_SWAP_HDW-case-from-RadeonCop.patch
Type: text/x-patch
Size: 1137 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/amd-gfx/attachments/20161104/ddc54307/attachment.bin>


More information about the amd-gfx mailing list