[PATCH 2/5] drm/amdgpu: fix a bunch of coding style issues in amdgpu_ttm.c
Michel Dänzer
michel at daenzer.net
Fri Sep 16 02:17:08 UTC 2016
On 15/09/16 10:10 PM, Christian König wrote:
> From: Christian König <christian.koenig at amd.com>
>
> No intented functional change.
>
> Signed-off-by: Christian König <christian.koenig at amd.com>
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c | 65 +++++++++++++++++++++------------
> 1 file changed, 42 insertions(+), 23 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c
> index 428ffb6..1965209 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c
> @@ -214,9 +214,11 @@ static void amdgpu_evict_flags(struct ttm_buffer_object *bo,
> switch (bo->mem.mem_type) {
> case TTM_PL_VRAM:
> if (rbo->adev->mman.buffer_funcs_ring->ready == false) {
> - amdgpu_ttm_placement_from_domain(rbo, AMDGPU_GEM_DOMAIN_CPU);
> + amdgpu_ttm_placement_from_domain(rbo,
> + AMDGPU_GEM_DOMAIN_CPU);
> } else {
> - amdgpu_ttm_placement_from_domain(rbo, AMDGPU_GEM_DOMAIN_GTT);
> + amdgpu_ttm_placement_from_domain(rbo,
> + AMDGPU_GEM_DOMAIN_GTT);
I don't see the point of this kind of change. We save all of 5 columns
of horizontal space, but for that we reduce readability by breaking up a
single line statement to multiple lines.
It makes more sense when saving a more significant amount of horizontal
space or when the statement already spans multiple lines though.
--
Earthling Michel Dänzer | http://www.amd.com
Libre software enthusiast | Mesa and X developer
More information about the amd-gfx
mailing list