[PATCH] drm/amdgpu: Fix comments in source code
Christian König
deathsimple at vodafone.de
Tue May 9 09:39:25 UTC 2017
Am 09.05.2017 um 03:26 schrieb Alex Xie:
> Signed-off-by: Alex Xie <AlexBin.Xie at amd.com>
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
> index 2704f88..480f3cd 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
> @@ -479,7 +479,7 @@ void amdgpu_doorbell_get_kfd_info(struct amdgpu_device *adev,
>
> /*
> * amdgpu_wb_*()
> - * Writeback is the method by which GPU updates special pages in memory
> + * Writeback is the method by which the GPU updates special pages in memory
> * with the status of certain GPU events (fences, ring pointers,etc.).
> */
Actually that comment as well as the name "writeback" is a bit outdated.
IIRC we also use the 32bit and 64bit addresses allocated with
amdgpu_wb_get for the wptr polling addresses.
In other words the GPU polls from the address and the CPU writes to them.
I wouldn't change the name, but noting that in the comment might be a
good idea.
Anyway the patch is Reviewed-by: Christian König <christian.koenig at amd.com>.
Regards,
Christian.
>
> @@ -506,7 +506,7 @@ static void amdgpu_wb_fini(struct amdgpu_device *adev)
> *
> * @adev: amdgpu_device pointer
> *
> - * Initialize writeback and allocates writeback memory (all asics).
> + * Initializes writeback and allocates writeback memory (all asics).
> * Used at driver startup.
> * Returns 0 on success or an -error on failure.
> */
> @@ -614,7 +614,7 @@ void amdgpu_wb_free_64bit(struct amdgpu_device *adev, u32 wb)
> * @mc: memory controller structure holding memory informations
> * @base: base address at which to put VRAM
> *
> - * Function will place try to place VRAM at base address provided
> + * Function will try to place VRAM at base address provided
> * as parameter (which is so far either PCI aperture address or
> * for IGP TOM base address).
> *
> @@ -636,7 +636,7 @@ void amdgpu_wb_free_64bit(struct amdgpu_device *adev, u32 wb)
> * ones)
> *
> * Note: IGP TOM addr should be the same as the aperture addr, we don't
> - * explicitly check for that thought.
> + * explicitly check for that though.
> *
> * FIXME: when reducing VRAM size align new size on power of 2.
> */
More information about the amd-gfx
mailing list