[amdgpu] script to generate a VCE 1.0 amdgpu compatible firmware

Christian K├Ânig ckoenig.leichtzumerken at gmail.com
Tue Nov 28 17:36:32 UTC 2017


Am 28.11.2017 um 17:34 schrieb Alexandre Demers:
> On 2017-11-23 00:53, Alexandre Demers wrote:
>> Hi,
>>
>> I just want to let you know that I'm still alive and still committed to
>> porting VCE 1.0 from radeon to amdgpu. However, for many reasons, I've
>> been pretty much unable to work on the code since my last communication.
>>
>> That being said, I've created a script based on Piotr Redlewski's work
>> to generate a compatible VCE 1.0 firmware with amdgpu. The script can be
>> found on GithubGist:
>> https://gist.github.com/Oxalin/ba9aa9c1c1912e68f76dadcad436d1a4
>>
>> Now, I've read the patchset sent by Redlewski for adding UVD on GCN 1
>> devices. Christian, since you were to see if AMD could release a new UVD
>> firmware with header and correct 40bit addressing, could you ask if an
>> official VCE 1.0 firmware with an official header (and whatever else
>> could be needed) be released at the same time?
>>
>> Cheers
>>
> The script now lives on github at the following address:
> git at github.com:Oxalin/vce-1.0-fw-convertor.git
>
> Christian, any news about official VCE and UVD firmwares from AMD?

Yeah, we talked about that just yesterday.

VCE shouldn't be to much of an issue. The main problem is that we need 
to figure out the latest tested version for SI and then throw that into 
the generator.

UVD is a bigger problem. Currently still looking into this.

Regards,
Christian.

>
> Alexandre Demers
>
> _______________________________________________
> amd-gfx mailing list
> amd-gfx at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/amd-gfx



More information about the amd-gfx mailing list