[PATCH] drm/amdgpu/display: dm/amdgpu: make dp phy debugfs for eDP

Harry Wentland harry.wentland at amd.com
Fri Oct 12 15:14:59 UTC 2018



On 2018-10-12 10:50 a.m., sunpeng.li at amd.com wrote:
> From: hersen wu <hersenxs.wu at amd.com>
> 
> [WHY] dp debugfs file does not exist for eDP under
>       /sys/kernel/debug/dri/0/eDP-1. the root is phy debugfs
>       is created for dp connector only.
> [HOW] for eDP connector, create phy debugfs too.
> 
> Signed-off-by: Hersen Wu <hersenxs.wu at amd.com>
> Reviewed-by: David Francis <David.Francis at amd.com>
> Acked-by: Leo Li <sunpeng.li at amd.com>
> ---
>  drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_debugfs.c | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_debugfs.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_debugfs.c
> index 0ef4a40..76a9c95 100644
> --- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_debugfs.c
> +++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_debugfs.c
> @@ -705,7 +705,9 @@ int connector_debugfs_init(struct amdgpu_dm_connector *connector)
>  	int i;
>  	struct dentry *ent, *dir = connector->base.debugfs_entry;
>  
> -	if (connector->base.connector_type == DRM_MODE_CONNECTOR_DisplayPort) {
> +	if (connector->base.connector_type == DRM_MODE_CONNECTOR_DisplayPort ||
> +			connector->base.connector_type ==
> +					DRM_MODE_CONNECTOR_eDP) {

Indenting looks funky. Would be nice to get that cleaned up before merge.

Anyways, beside the bikeshedding this is
Reviewed-by: Harry Wentland <harry.wentland at amd.com>

Harry

>  		for (i = 0; i < ARRAY_SIZE(dp_debugfs_entries); i++) {
>  			ent = debugfs_create_file(dp_debugfs_entries[i].name,
>  						  0644,
> 


More information about the amd-gfx mailing list