[PATCH 00/19] [Set 2] Rid W=1 warnings from GPU

Lee Jones lee.jones at linaro.org
Sat Nov 7 15:07:10 UTC 2020


On Sat, 07 Nov 2020, Christian König wrote:

> Well that's quite a patch set.
> 
> First of all can you separate this a bit more by driver? I'm assuming we
> maintainers are supposed to pick that up and apply it.

I'm not sure what would achieve?  It's not a pull-request.

Either way, patches should be applied individually.

> radeon and amdgpu can stick together since that is mostly Alex and me, but
> I'm not sure if we want to do some of the suggested changes to radeon.

That's fine.  Just review, providing your reasons as to why they are
not suitable and we'll work through the issues together, patch by
patch.

> Going to pick up the single TTM change for upstreaming.

Thanks.

> Am 06.11.20 um 22:49 schrieb Lee Jones:
> > This set is part of a larger effort attempting to clean-up W=1
> > kernel builds, which are currently overwhelmingly riddled with
> > niggly little warnings.
> > 
> > There are 5000 warnings to work through.  It will take a couple more
> > sets.  Although, ("drm/amd/display/dc/basics/fixpt31_32: Move
> > variables to where they're used") does take care of 2000 of them!
> > 
> > Lee Jones (19):
> >    drm/ttm/ttm_range_manager: Demote non-conformant kernel-doc header
> >    drm/r128/ati_pcigart: Source file headers are not good candidates for
> >      kernel-doc
> >    drm/selftests/test-drm_dp_mst_helper: Move
> >      'sideband_msg_req_encode_decode' onto the heap
> >    drm/mga/mga_dma: Demote kernel-doc abusers to standard comment blocks
> >    drm/mga/mga_state: Remove unused variable 'buf_priv'
> >    drm/radeon/atom: Move prototype into shared location
> >    drm/radeon/radeon_kms: Include header containing our own prototypes
> >    drm/omapdrm/omap_gem: Fix misnamed and missing parameter descriptions
> >    drm/omapdrm/omap_dmm_tiler: Demote abusive use of kernel-doc format
> >    drm/radeon/radeon: Move prototype into shared header
> >    drm/radeon/radeon_drv: Source file headers are not good candidates for
> >      kernel-doc
> >    drm/amd/display/dc/basics/fixpt31_32: Move variables to where they're
> >      used
> >    drm/radeon/radeon_drv: Move prototypes to a shared headerfile
> >    drm/amd/amdgpu/amdgpu_device: Provide documentation for 'reg_addr'
> >      params
> >    drm/radeon: Move prototypes to shared header
> >    drm/amd/amdgpu/amdgpu_kms: Remove 'struct drm_amdgpu_info_device
> >      dev_info' from the stack
> >    drm/radeon/radeon_kms: Fix misnaming of 'radeon_info_ioctl's dev param
> >    drm/radeon/atombios_crtc: Remove description of non-existent function
> >      param 'encoder'
> >    drm/v3d/v3d_drv: Remove unused static variable 'v3d_v3d_pm_ops'
> > 
> >   drivers/gpu/drm/amd/amdgpu/amdgpu_device.c    |   2 +
> >   drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c       | 104 +++++++++---------
> >   .../drm/amd/display/dc/basics/fixpt31_32.c    |   5 +
> >   .../gpu/drm/amd/display/include/fixed31_32.h  |   6 -
> >   drivers/gpu/drm/mga/mga_dma.c                 |  10 +-
> >   drivers/gpu/drm/mga/mga_state.c               |   2 -
> >   drivers/gpu/drm/omapdrm/omap_dmm_tiler.c      |   6 +-
> >   drivers/gpu/drm/omapdrm/omap_gem.c            |   3 +-
> >   drivers/gpu/drm/r128/ati_pcigart.c            |   2 +-
> >   drivers/gpu/drm/radeon/atom.h                 |   6 +
> >   drivers/gpu/drm/radeon/atombios_crtc.c        |   1 -
> >   drivers/gpu/drm/radeon/atombios_encoders.c    |   4 -
> >   drivers/gpu/drm/radeon/radeon.h               |   6 +
> >   drivers/gpu/drm/radeon/radeon_device.c        |   1 +
> >   drivers/gpu/drm/radeon/radeon_device.h        |  32 ++++++
> >   drivers/gpu/drm/radeon/radeon_display.c       |   4 -
> >   drivers/gpu/drm/radeon/radeon_drv.c           |  11 +-
> >   drivers/gpu/drm/radeon/radeon_drv.h           |   7 ++
> >   drivers/gpu/drm/radeon/radeon_kms.c           |   3 +-
> >   .../drm/selftests/test-drm_dp_mst_helper.c    |  11 +-
> >   drivers/gpu/drm/ttm/ttm_range_manager.c       |   2 +-
> >   drivers/gpu/drm/v3d/v3d_drv.c                 |  36 ------
> >   22 files changed, 138 insertions(+), 126 deletions(-)
> >   create mode 100644 drivers/gpu/drm/radeon/radeon_device.h
> > 
> > Cc: Alex Deucher <alexander.deucher at amd.com>
> > Cc: amd-gfx at lists.freedesktop.org
> > Cc: Andy Gross <andy.gross at ti.com>
> > Cc: by <jhartmann at precisioninsight.com>
> > Cc: Christian Koenig <christian.koenig at amd.com>
> > Cc: "Christian König" <christian.koenig at amd.com>
> > Cc: Daniel Vetter <daniel at ffwll.ch>
> > Cc: David Airlie <airlied at linux.ie>
> > Cc: dri-devel at lists.freedesktop.org
> > Cc: Eric Anholt <eric at anholt.net>
> > Cc: Faith <faith at valinux.com>
> > Cc: Gareth Hughes <gareth at valinux.com>
> > Cc: Harry Wentland <harry.wentland at amd.com>
> > Cc: Huang Rui <ray.huang at amd.com>
> > Cc: Jeff Hartmann <jhartmann at valinux.com>
> > Cc: Keith Whitwell <keith at tungstengraphics.com>
> > Cc: Leo Li <sunpeng.li at amd.com>
> > Cc: linaro-mm-sig at lists.linaro.org
> > Cc: linux-media at vger.kernel.org
> > Cc: Philipp Zabel <p.zabel at pengutronix.de>
> > Cc: Rob Clark <rob.clark at linaro.org>
> > Cc: Rob Clark <rob at ti.com>
> > Cc: Sumit Semwal <sumit.semwal at linaro.org>
> > Cc: Tomi Valkeinen <tomi.valkeinen at ti.com>
> 

-- 
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog


More information about the amd-gfx mailing list