[PATCH 00/20] [Set 3] Rid W=1 warnings from GPU

Lee Jones lee.jones at linaro.org
Tue Nov 10 07:20:46 UTC 2020


On Mon, 09 Nov 2020, Alex Deucher wrote:

> On Mon, Nov 9, 2020 at 4:19 PM Lee Jones <lee.jones at linaro.org> wrote:
> >
> > This set is part of a larger effort attempting to clean-up W=1
> > kernel builds, which are currently overwhelmingly riddled with
> > niggly little warnings.
> >
> > This set takes the running (decreasing) total from 5000 before
> > [Set 1] down to 2300.
> >
> > Lee Jones (20):
> >   drm/radeon/radeon_ttm: Place declaration of 'rdev' in same clause as
> >     its use
> >   drm/radeon: Move radeon_ttm{init,fini} to shared location
> >   drm/radeon/radeon_fence: Demote some non-conformant kernel-doc headers
> >     and fix another
> >   drm/radeon: Move 'radeon_add_legacy_encoder' prototype to shared
> >     header
> >   drm/radeon: Move 'radeon_add_legacy_encoder's prototype to shared
> >     location
> >   drm/radeon/radeon_connectors: Strip out set but unused variable 'ret'
> >   drm/radeon/radeon_display: Remove unused variable 'mod'
> >   drm/radeon/radeon_i2c: Remove pointless function header
> >   drm/radeon/radeon_irq_kms: Demote non-conformant kernel-doc fix
> >     another
> >   drm/radeon/radeon_ring: Add missing function parameters 'rdev' and
> >     'data'
> >   drm/radeon/r600: Strip out set but unused 'tmp' variables
> >   drm/radeon/radeon_cs: Fix a bunch of doc-rot issues
> >   drm/radeon/evergreen: Move 'rv770_set_clk_bypass_mode' prototype to
> >     shared location
> >   drm/radeon: Move 'radeon_pm_acpi_event_handler' prototype into shared
> >     header
> >   drm/radeon/r600d: Move 'rc600_*' prototypes into shared header
> >   drm/radeon/radeon_audio: Move 'dce3_2_*' prototypes to shared location
> >   drm/radeon/evergreend: Move 'evergreen_*' and 'sumo_*' prototypes out
> >     to shared location
> >   drm/radeon/radeon_display: Fix function doc formatting and missing
> >     param issues
> >   drm/radeon/r600: Fix a misnamed parameter description and a formatting
> >     issue
> >   drm/radeon/cik: Fix a bunch of function parameter descriptions
> >
> >  drivers/gpu/drm/radeon/cik.c               | 10 +++----
> >  drivers/gpu/drm/radeon/evergreen.c         |  1 -
> >  drivers/gpu/drm/radeon/ni.c                | 16 ----------
> >  drivers/gpu/drm/radeon/r600.c              | 11 +++----
> >  drivers/gpu/drm/radeon/r600d.h             | 14 +++++++++
> >  drivers/gpu/drm/radeon/radeon.h            | 34 ++++++++++++++++++++++
> >  drivers/gpu/drm/radeon/radeon_acpi.c       |  2 --
> >  drivers/gpu/drm/radeon/radeon_atombios.c   |  5 ----
> >  drivers/gpu/drm/radeon/radeon_audio.c      | 23 +--------------
> >  drivers/gpu/drm/radeon/radeon_audio.h      | 12 ++++++++
> >  drivers/gpu/drm/radeon/radeon_combios.c    |  5 ----
> >  drivers/gpu/drm/radeon/radeon_connectors.c |  4 +--
> >  drivers/gpu/drm/radeon/radeon_cs.c         | 12 ++++----
> >  drivers/gpu/drm/radeon/radeon_display.c    | 17 +++++------
> >  drivers/gpu/drm/radeon/radeon_encoders.c   |  3 --
> >  drivers/gpu/drm/radeon/radeon_fence.c      |  6 ++--
> >  drivers/gpu/drm/radeon/radeon_i2c.c        |  4 ---
> >  drivers/gpu/drm/radeon/radeon_irq_kms.c    |  6 ++--
> >  drivers/gpu/drm/radeon/radeon_object.c     |  2 --
> >  drivers/gpu/drm/radeon/radeon_ring.c       |  3 ++
> >  drivers/gpu/drm/radeon/radeon_ttm.c        |  8 ++---
> >  drivers/gpu/drm/radeon/si.c                |  6 ----
> >  22 files changed, 96 insertions(+), 108 deletions(-)
> 
> Instead of just dumping everything in radeon.h, I think it would be
> cleaner to add new headers that match the .c files that define them.
> E.g., add evergreen.h and put all the stuff from evergreen.c in there.
> Add rv770.h and add all the stuff defined in rv770.c, etc.

This was my original solution, but Sam pushed back.

Please can you decide amongst yourselves what is the best way forward?

I will abide by whatever you decide.

> > Cc: Alex Deucher <alexander.deucher at amd.com>
> > Cc: amd-gfx at lists.freedesktop.org
> > Cc: "Christian König" <christian.koenig at amd.com>
> > Cc: Daniel Vetter <daniel at ffwll.ch>
> > Cc: David Airlie <airlied at linux.ie>
> > Cc: dri-devel at lists.freedesktop.org
> > Cc: Jerome Glisse <glisse at freedesktop.org>
> > Cc: linaro-mm-sig at lists.linaro.org
> > Cc: linux-media at vger.kernel.org
> > Cc: report to <xorg-driver-ati at lists.x.org>
> > Cc: Slava Grigorev <slava.grigorev at amd.com>
> > Cc: Sumit Semwal <sumit.semwal at linaro.org>
> >
> > _______________________________________________
> > dri-devel mailing list
> > dri-devel at lists.freedesktop.org
> > https://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog


More information about the amd-gfx mailing list