[PATCH] drm/amdgpu: Make use of the helper macro SET_RUNTIME_PM_OPS()
Alex Deucher
alexdeucher at gmail.com
Mon Aug 30 13:22:02 UTC 2021
On Sat, Aug 28, 2021 at 4:41 AM Cai Huoqing <caihuoqing at baidu.com> wrote:
>
> Use the helper macro SET_RUNTIME_PM_OPS() instead of the verbose
> operators ".runtime_suspend/.runtime_resume/.runtime_idle", because
> the SET_RUNTIME_PM_OPS() is a nice helper macro that could be brought
> in to make code a little clearer, a little more concise.
>
I think this makes readability worse and just causes code churn.
Alex
> Signed-off-by: Cai Huoqing <caihuoqing at baidu.com>
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
> index b6640291f980..9e5fb8d2e0e0 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
> @@ -1699,6 +1699,8 @@ long amdgpu_drm_ioctl(struct file *filp,
> }
>
> static const struct dev_pm_ops amdgpu_pm_ops = {
> + SET_RUNTIME_PM_OPS(amdgpu_pmops_runtime_suspend,
> + amdgpu_pmops_runtime_resume, amdgpu_pmops_runtime_idle)
> .prepare = amdgpu_pmops_prepare,
> .complete = amdgpu_pmops_complete,
> .suspend = amdgpu_pmops_suspend,
> @@ -1707,9 +1709,6 @@ static const struct dev_pm_ops amdgpu_pm_ops = {
> .thaw = amdgpu_pmops_thaw,
> .poweroff = amdgpu_pmops_poweroff,
> .restore = amdgpu_pmops_restore,
> - .runtime_suspend = amdgpu_pmops_runtime_suspend,
> - .runtime_resume = amdgpu_pmops_runtime_resume,
> - .runtime_idle = amdgpu_pmops_runtime_idle,
> };
>
> static int amdgpu_flush(struct file *f, fl_owner_t id)
> --
> 2.25.1
>
More information about the amd-gfx
mailing list