[RESEND 00/26] Rid W=1 warnings from GPU

Daniel Vetter daniel at ffwll.ch
Thu Jun 3 11:34:00 UTC 2021


On Wed, Jun 02, 2021 at 03:32:34PM +0100, Lee Jones wrote:
> Some off these patches have been knocking around for a while.
> 
> Who will hoover them up please?
> 
> This set is part of a larger effort attempting to clean-up W=1
> kernel builds, which are currently overwhelmingly riddled with
> niggly little warnings.
> 
> Lee Jones (26):
>   drm/mediatek/mtk_disp_color: Strip incorrect doc and demote header
>   drm/mediatek/mtk_disp_gamma: Strip and demote non-conformant
>     kernel-doc header
>   drm/mediatek/mtk_disp_ovl: Strip and demote non-conformant header
>   drm/mediatek/mtk_disp_rdma: Strip and demote non-conformant kernel-doc
>     header
>   drm/sti/sti_hdmi_tx3g4c28phy: Provide function names for kernel-doc
>     headers
>   drm/sti/sti_hda: Provide missing function names
>   drm/sti/sti_tvout: Provide a bunch of missing function names
>   drm/sti/sti_hqvdp: Fix incorrectly named function 'sti_hqvdp_vtg_cb()'
>   drm/msm/disp/dpu1/dpu_encoder_phys_cmd: Remove unused variable
>     'cmd_enc'
>   drm/msm/disp/dpu1/dpu_hw_interrupts: Demote a bunch of kernel-doc
>     abuses
>   drm/msm/disp/dpu1/dpu_plane: Fix a couple of naming issues
>   drm/msm/msm_gem: Demote kernel-doc abuses
>   drm/msm/dp/dp_catalog: Correctly document param 'dp_catalog'
>   drm/msm/dp/dp_link: Fix some potential doc-rot
>   drm/nouveau/nvkm/subdev/mc/tu102: Make functions called by reference
>     static
>   drm/amd/display/dc/dce/dce_transform: Remove superfluous
>     re-initialisation of DCFE_MEM_LIGHT_SLEEP_CNTL,
>   drm/xlnx/zynqmp_disp: Fix incorrectly named enum
>     'zynqmp_disp_layer_id'
>   drm/xlnx/zynqmp_dp: Fix incorrectly name function 'zynqmp_dp_train()'
>   drm/ttm/ttm_tt: Demote non-conformant kernel-doc header
>   drm/panel/panel-raspberrypi-touchscreen: Demote kernel-doc abuse
>   drm/panel/panel-sitronix-st7701: Demote kernel-doc abuse
>   drm/vgem/vgem_drv: Standard comment blocks should not use kernel-doc
>     format
>   drm/exynos/exynos7_drm_decon: Fix incorrect naming of
>     'decon_shadow_protect_win()'
>   drm/exynos/exynos_drm_ipp: Fix documentation for
>     'exynos_drm_ipp_get_{caps,res}_ioctl()'
>   drm/vboxvideo/hgsmi_base: Place function names into headers
>   drm/vboxvideo/modesetting: Provide function names for prototype
>     headers

Except for msm (Rob Clark promised on irc he'll pick them up for 5.14
soon) and amd (Alex is on top of things I think) I picked them all up and
merged into drm-misc-next.

Thanks, Daniel

> 
>  .../drm/amd/display/dc/dce/dce_transform.h    |  3 +-
>  drivers/gpu/drm/exynos/exynos7_drm_decon.c    |  2 +-
>  drivers/gpu/drm/exynos/exynos_drm_ipp.c       |  4 +--
>  drivers/gpu/drm/mediatek/mtk_disp_color.c     |  3 +-
>  drivers/gpu/drm/mediatek/mtk_disp_gamma.c     |  4 +--
>  drivers/gpu/drm/mediatek/mtk_disp_ovl.c       |  3 +-
>  drivers/gpu/drm/mediatek/mtk_disp_rdma.c      |  4 +--
>  .../drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c  |  4 ---
>  .../gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c | 32 +++++++++----------
>  drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c     |  4 +--
>  drivers/gpu/drm/msm/dp/dp_catalog.c           |  2 +-
>  drivers/gpu/drm/msm/dp/dp_link.c              |  6 ++--
>  drivers/gpu/drm/msm/msm_gem.c                 |  4 +--
>  .../gpu/drm/nouveau/nvkm/subdev/mc/tu102.c    |  6 ++--
>  .../drm/panel/panel-raspberrypi-touchscreen.c |  2 +-
>  drivers/gpu/drm/panel/panel-sitronix-st7701.c |  2 +-
>  drivers/gpu/drm/sti/sti_hda.c                 |  6 ++--
>  drivers/gpu/drm/sti/sti_hdmi_tx3g4c28phy.c    |  4 +--
>  drivers/gpu/drm/sti/sti_hqvdp.c               |  2 +-
>  drivers/gpu/drm/sti/sti_tvout.c               | 18 +++++------
>  drivers/gpu/drm/ttm/ttm_tt.c                  |  2 +-
>  drivers/gpu/drm/vboxvideo/hgsmi_base.c        | 19 +++++++----
>  drivers/gpu/drm/vboxvideo/modesetting.c       | 20 +++++++-----
>  drivers/gpu/drm/vgem/vgem_drv.c               |  2 +-
>  drivers/gpu/drm/xlnx/zynqmp_disp.c            |  2 +-
>  drivers/gpu/drm/xlnx/zynqmp_dp.c              |  2 +-
>  26 files changed, 80 insertions(+), 82 deletions(-)
> 
> Cc: Adam Jackson <ajax at redhat.com>
> Cc: Ajay Kumar <ajaykumar.rs at samsung.com>
> Cc: Akshu Agarwal <akshua at gmail.com>
> Cc: Alex Deucher <alexander.deucher at amd.com>
> Cc: Alistair Popple <apopple at nvidia.com>
> Cc: amd-gfx at lists.freedesktop.org
> Cc: AngeloGioacchino Del Regno <angelogioacchino.delregno at somainline.org>
> Cc: Benjamin Gaignard <benjamin.gaignard at linaro.org>
> Cc: Ben Skeggs <bskeggs at redhat.com>
> Cc: Ben Widawsky <ben at bwidawsk.net>
> Cc: Chandan Uddaraju <chandanu at codeaurora.org>
> Cc: Christian Koenig <christian.koenig at amd.com>
> Cc: "Christian König" <christian.koenig at amd.com>
> Cc: Chun-Kuang Hu <chunkuang.hu at kernel.org>
> Cc: Daniel Vetter <daniel at ffwll.ch>
> Cc: David Airlie <airlied at linux.ie>
> Cc: dri-devel at lists.freedesktop.org
> Cc: Eric Anholt <eric at anholt.net>
> Cc: Fabien Dessenne <fabien.dessenne at st.com>
> Cc: freedreno at lists.freedesktop.org
> Cc: Hans de Goede <hdegoede at redhat.com>
> Cc: Harry Wentland <harry.wentland at amd.com>
> Cc: Huang Rui <ray.huang at amd.com>
> Cc: Hyun Kwon <hyun.kwon at xilinx.com>
> Cc: Inki Dae <inki.dae at samsung.com>
> Cc: Jagan Teki <jagan at amarulasolutions.com>
> Cc: Joonyoung Shim <jy0922.shim at samsung.com>
> Cc: Krishna Manikandan <mkrishn at codeaurora.org>
> Cc: Krzysztof Kozlowski <krzysztof.kozlowski at canonical.com>
> Cc: Kuogee Hsieh <khsieh at codeaurora.org>
> Cc: Kyungmin Park <kyungmin.park at samsung.com>
> Cc: Laurent Pinchart <laurent.pinchart at ideasonboard.com>
> Cc: Leo Li <sunpeng.li at amd.com>
> Cc: linaro-mm-sig at lists.linaro.org
> Cc: linux-arm-kernel at lists.infradead.org
> Cc: linux-arm-msm at vger.kernel.org
> Cc: linux-mediatek at lists.infradead.org
> Cc: linux-media at vger.kernel.org
> Cc: linux-samsung-soc at vger.kernel.org
> Cc: Marek Szyprowski <m.szyprowski at samsung.com>
> Cc: Matthias Brugger <matthias.bgg at gmail.com>
> Cc: Mauro Rossi <issor.oruam at gmail.com>
> Cc: Michal Simek <michal.simek at xilinx.com>
> Cc: nouveau at lists.freedesktop.org
> Cc: Philipp Zabel <p.zabel at pengutronix.de>
> Cc: Rob Clark <robdclark at gmail.com>
> Cc: Sam Ravnborg <sam at ravnborg.org>
> Cc: Sean Paul <sean at poorly.run>
> Cc: Seung-Woo Kim <sw0312.kim at samsung.com>
> Cc: Stephen Boyd <swboyd at chromium.org>
> Cc: Sumit Semwal <sumit.semwal at linaro.org>
> Cc: Thierry Reding <thierry.reding at gmail.com>
> Cc: Vincent Abriou <vincent.abriou at st.com>
> -- 
> 2.31.1
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch


More information about the amd-gfx mailing list