[PATCH 14/15] drm/amd: cleanup: drm_modeset_lock_all() --> DRM_MODESET_LOCK_ALL_BEGIN()
Fernando Ramos
greenfoo at u92.eu
Fri Sep 17 23:17:01 UTC 2021
> > + struct drm_modeset_acquire_ctx ctx;
> > int r;
> > + int ret;
>
> Relocate ret with r please
Done!
> > - drm_modeset_unlock_all(dev);
> > + DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
>
> You should check ret here
Done!
> > int r;
> > + int ret;
>
> Relocate ret with r
Done!
> > - drm_modeset_unlock_all(dev);
> > + DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
> >
> > return 0;
>
> Return ret
Done!
> > diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> > index 9b1fc54555ee..5196c1d26f87 100644
> > @@ -2661,13 +2657,18 @@ static void handle_hpd_irq(void *param)
> >
> > amdgpu_dm_update_connector_after_detect(aconnector);
> >
> > - drm_modeset_lock_all(dev);
> > - dm_restore_drm_connector_state(dev, connector);
> > - drm_modeset_unlock_all(dev);
> > -
> > - if (aconnector->base.force == DRM_FORCE_UNSPECIFIED)
> > - drm_kms_helper_hotplug_event(dev);
> > + } else {
> > + goto out;
> > }
> > +
> > + DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
> > + dm_restore_drm_connector_state(dev, connector);
> > + DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
>
> Check ret here please
This function ("handle_hpd_irq") returns void. What would the appropriate way of
checking the error be?
> > @@ -2841,14 +2838,17 @@ static void handle_hpd_rx_irq(void *param)
> >
> > amdgpu_dm_update_connector_after_detect(aconnector);
> >
> > + } else {
> > + goto finish;
>
> You used 'out' above and 'finish' here. It would be nice to be consistent with
> naming, I see 'out' a lot more than 'finish', so my vote would be to change this
> label to 'out'.
I originally used "out", but turns out there is already an "out" label in this
function :)
I then searched for other "go to end" labels and found "finish" being used in
this same file.
But I can rename it to somehitng else ("out2" maybe?) to make it less confusing.
> > + }
> >
> > - drm_modeset_lock_all(dev);
> > - dm_restore_drm_connector_state(dev, connector);
> > - drm_modeset_unlock_all(dev);
> > + DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
> > + dm_restore_drm_connector_state(dev, connector);
> > + DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
>
> Check ret here?
This is another irq-like function returning void.
What can we do here after having checked the error?
> > +#include <drm/drm_drv.h>
>
> Top-level headers generally come above the driver headers. Also, now that I think
> about this a bit more, all of the new includes in this set should probably be
> for 'drm_modeset_lock.h' instead of 'drm_drv.h'.
Ok. Let me try that.
> > @@ -1259,13 +1257,16 @@ static ssize_t trigger_hotplug(struct file *f, const char __user *buf,
> > + DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
> > + dm_restore_drm_connector_state(dev, connector);
> > + DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
>
> Check ret here?
This is a .write file_operations function expected to return a "size". Is it ok
for it to return an error? I guess so, right?
More information about the amd-gfx
mailing list