[PATCH 30/66] drm/amdgpu: add DCI HWIP
Harry Wentland
harry.wentland at amd.com
Fri Sep 24 20:40:24 UTC 2021
On 2021-09-24 15:58, Alex Deucher wrote:
> On Thu, Sep 23, 2021 at 11:43 AM Harry Wentland <harry.wentland at amd.com> wrote:
>>
>> On 2021-09-21 14:06, Alex Deucher wrote:
>>> So we can track grab the appropriate DCE info out of the
>>> IP discovery table. This is a separare IP from DCN.
>>>
>>
>> I've never looked at the HWID stuff before. Do I understand it correctly
>> that DCI_HWID is for DCE IP and DMU_HWID for DCN IP?
>
> yes.
>
Thanks.
>>
>> In that case it might be good to rename DCE_HWIP to DCN_HWIP to avoid
>> confusion. Ideally as a prep patch so as to avoid excessive renames
>> later.
>
> The names align with what we use internally in the IP discovery
> documentation. I'd prefer to keep them aligned, but I guess it's not
> a big deal.
>
In that case it's fine.
Patch is Acked-by: Harry Wentland <harry.wentland at amd.com>
Harry
> Alex
>
>
>>
>> Harry
>>
>>> Signed-off-by: Alex Deucher <alexander.deucher at amd.com>
>>> ---
>>> drivers/gpu/drm/amd/amdgpu/amdgpu.h | 1 +
>>> drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c | 1 +
>>> 2 files changed, 2 insertions(+)
>>>
>>> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu.h b/drivers/gpu/drm/amd/amdgpu/amdgpu.h
>>> index 8df4be702870..815db33190ca 100644
>>> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu.h
>>> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu.h
>>> @@ -756,6 +756,7 @@ enum amd_hw_ip_block_type {
>>> UMC_HWIP,
>>> RSMU_HWIP,
>>> XGMI_HWIP,
>>> + DCI_HWIP,
>>> MAX_HWIP
>>> };
>>>
>>> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c
>>> index 048a08d7f480..6a993043badc 100644
>>> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c
>>> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c
>>> @@ -149,6 +149,7 @@ static int hw_id_map[MAX_HWIP] = {
>>> [CLK_HWIP] = CLKA_HWID,
>>> [UMC_HWIP] = UMC_HWID,
>>> [XGMI_HWIP] = XGMI_HWID,
>>> + [DCI_HWIP] = DCI_HWID,
>>> };
>>>
>>> static int amdgpu_discovery_read_binary(struct amdgpu_device *adev, uint8_t *binary)
>>>
>>
More information about the amd-gfx
mailing list