[PATCH] drm/amdgpu: use sysfs_emit() to instead of scnprintf()
Luben Tuikov
luben.tuikov at amd.com
Thu Dec 1 16:57:40 UTC 2022
Reviewed-by: Luben Tuikov <luben.tuikov at amd.com>
Regards,
Luben
On 2022-11-30 21:24, ye.xingchen at zte.com.cn wrote:
> From: ye xingchen <ye.xingchen at zte.com.cn>
>
> Replace the open-code with sysfs_emit() to simplify the code.
>
> Signed-off-by: ye xingchen <ye.xingchen at zte.com.cn>
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
> index 077404a9c935..ad490c1e2f57 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
> @@ -1267,7 +1267,7 @@ static ssize_t amdgpu_ras_sysfs_features_read(struct device *dev,
> struct amdgpu_ras *con =
> container_of(attr, struct amdgpu_ras, features_attr);
>
> - return scnprintf(buf, PAGE_SIZE, "feature mask: 0x%x\n", con->features);
> + return sysfs_emit(buf, "feature mask: 0x%x\n", con->features);
> }
>
> static void amdgpu_ras_sysfs_remove_bad_page_node(struct amdgpu_device *adev)
More information about the amd-gfx
mailing list