[PATCH 0/3] lib/string_helpers: Add a few string helpers
David.Laight at ACULAB.COM
Thu Jan 20 09:12:00 UTC 2022
> Yeah, and I am sorry for bikeshedding. Honestly, I do not know what is
> better. This is why I do not want to block this series when others
> like this.
> My main motivation is to point out that:
> might be, for some people, more eye bleeding than
> enable ? "enable" : "disable"
Indeed - you need to look the former up, wasting brain time.
> The problem is not that visible with yesno() and onoff(). But as you said,
> onoff() confliscts with variable names. And enabledisable() sucks.
> As a result, there is a non-trivial risk of two mass changes:
> - contition ? "yes" : "no"
> + yesno(condition)
> a few moths later:
> - yesno(condition)
> + str_yes_no(condition)
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)
More information about the amd-gfx