[PATCH] drm/amd/display: Use kcalloc() instead of kzalloc()
Rodrigo Siqueira Jordao
Rodrigo.Siqueira at amd.com
Wed Feb 21 23:04:18 UTC 2024
On 1/28/24 02:04, Lenko Donchev wrote:
> We are trying to get rid of all multiplications from allocation
> functions to prevent integer overflows. Here the multiplication is
> obviously safe, but using kcalloc() is more appropriate and improves
> readability. This patch has no effect on runtime behavior.
>
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> Link: https://github.com/KSPP/linux/issues/162
>
> Signed-off-by: Lenko Donchev <lenko.donchev at gmail.com>
> ---
> drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c b/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c
> index 5c9a30211c10..b67cd78e7c58 100644
> --- a/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c
> +++ b/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c
> @@ -164,7 +164,7 @@ static void dpcd_extend_address_range(
> if (new_addr_range.start != in_address || new_addr_range.end != end_address) {
> *out_address = new_addr_range.start;
> *out_size = ADDRESS_RANGE_SIZE(new_addr_range.start, new_addr_range.end);
> - *out_data = kzalloc(*out_size * sizeof(**out_data), GFP_KERNEL);
> + *out_data = kcalloc(*out_size, sizeof(**out_data), GFP_KERNEL);
> }
> }
>
lgtm,
Reviewed-by: Rodrigo Siqueira <Rodrigo.Siqueira at amd.com>
More information about the amd-gfx
mailing list