<html>
<head>
<meta http-equiv="Content-Type" content="text/html;
charset=windows-1252">
</head>
<body text="#000000" bgcolor="#FFFFFF">
<div class="moz-cite-prefix">
<blockquote type="cite">
<p style="margin-top: 0px; margin-bottom: 0px;">I'd prefer to
keep the old structures: common interfaces in amdgpu_psp.c/.h,
and IP specific ones in IP specific file.</p>
</blockquote>
That works for me as well.<br>
<br>
Key take away from the change overview is this:<font size="2"><span
style="font-size:11pt;"></span></font><br>
<font size="2"><span style="font-size:11pt;"></span></font>
<blockquote type="cite"><font size="2"><span
style="font-size:11pt;">
> drivers/gpu/drm/amd/amdgpu/psp_v10_0.c | 381
+----------------<br>
> drivers/gpu/drm/amd/amdgpu/psp_v11_0.c | 539
+-----------------------<br>
> drivers/gpu/drm/amd/amdgpu/psp_v3_1.c | 480
+--------------------</span></font></blockquote>
That looks like we can move a good bunch of the per IP specific
code into the common interface. And that is something I really
like to see.<br>
<br>
No strong opinion if the common code should go into
amdgpu_psp.c/h, amdgpu_xgmi.c/h or amdgpu_psp_xgmi.c/h.<br>
<br>
The only restriction I have is that we should just stick with the
existing naming convention.<br>
<br>
Christian.<br>
<br>
Am 02.01.19 um 11:21 schrieb Zhang, Hawking:<br>
</div>
<blockquote type="cite"
cite="mid:BYAPR12MB2632A5BB82C2FCE97AF9E7ECFC8C0@BYAPR12MB2632.namprd12.prod.outlook.com">
<meta http-equiv="Content-Type" content="text/html;
charset=windows-1252">
<style type="text/css" style="display:none;"><!-- P {margin-top:0;margin-bottom:0;} --></style>
<div id="divtagdefaultwrapper"
style="font-size:12pt;color:#000000;font-family:Calibri,Helvetica,sans-serif;"
dir="ltr">
<p style="margin-top: 0px; margin-bottom: 0px;">I'd prefer to
keep the old structures: common interfaces in amdgpu_psp.c/.h,
and IP specific ones in IP specific file.</p>
<p style="margin-top: 0px; margin-bottom: 0px;"><br>
</p>
<p style="margin-top: 0px; margin-bottom: 0px;">No matter it's
something related to ASD,TMR, or XGMI.etc, all of these are
just communication/handshake jobs between driver and psp fw.
Driver plays messenger role with several psp cmd that are
shared among ASIC generations. a unified amdgpu_psp.c file is
good enough to hold all the common stuffs.
</p>
<p style="margin-top: 0px; margin-bottom: 0px;"><br>
</p>
<p style="margin-top: 0px; margin-bottom: 0px;">Regards,<br>
Hawking<br>
</p>
</div>
<hr style="display:inline-block;width:98%" tabindex="-1">
<div id="divRplyFwdMsg" dir="ltr"><font style="font-size:11pt"
face="Calibri, sans-serif" color="#000000"><b>From:</b>
Christian König <a class="moz-txt-link-rfc2396E" href="mailto:ckoenig.leichtzumerken@gmail.com"><ckoenig.leichtzumerken@gmail.com></a><br>
<b>Sent:</b> Wednesday, January 2, 2019 6:01:56 PM<br>
<b>To:</b> Quan, Evan; <a class="moz-txt-link-abbreviated" href="mailto:amd-gfx@lists.freedesktop.org">amd-gfx@lists.freedesktop.org</a><br>
<b>Cc:</b> Deucher, Alexander; Xu, Feifei; Huang, Ray; Zhang,
Hawking<br>
<b>Subject:</b> Re: [PATCH 0/9] PSP cleanup</font>
<div> </div>
</div>
<div class="BodyFragment"><font size="2"><span
style="font-size:11pt;">
<div class="PlainText">The general idea looks good, but can
we change the file and symbol
<br>
naming a bit?<br>
<br>
So far we have named all non-ip version related functions
amdgpu_* and <br>
ip related functions ip_version.<br>
<br>
E.g. following this xgmi functions should go into
amdgpu_xgmi.c and not <br>
psp_xgmi.c<br>
<br>
Christian.<br>
<br>
Am 02.01.19 um 10:21 schrieb Evan Quan:<br>
> *** BLURB HERE ***<br>
><br>
> Evan Quan (9):<br>
> drm/amdgpu: separate the PSP ring related APIs<br>
> drm/amdgpu: separate commonly used PSP APIs<br>
> drm/amdgpu: separate the xgmi related APIs<br>
> drm/amdgpu: separate the tmr related APIs<br>
> drm/amdgpu: separate the asd related APIs<br>
> drm/amdgpu: drop useless PSP APIs and structures<br>
> drm/amdgpu: check PSP support before adding the ip
block<br>
> drm/amdgpu: make PSP sub modules(ASD/XGMI/TMR)
support configurable<br>
> drm/amdgpu: move psp_funcs related to a more
proper place<br>
><br>
> drivers/gpu/drm/amd/amdgpu/Makefile | 7 +-<br>
> drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 504
+++-------------------<br>
> drivers/gpu/drm/amd/amdgpu/amdgpu_psp.h | 93 +---<br>
> drivers/gpu/drm/amd/amdgpu/psp_asd.c | 86 ++++<br>
> drivers/gpu/drm/amd/amdgpu/psp_asd.h | 32 ++<br>
> drivers/gpu/drm/amd/amdgpu/psp_cmn.c | 289
+++++++++++++<br>
> drivers/gpu/drm/amd/amdgpu/psp_cmn.h | 84 ++++<br>
> drivers/gpu/drm/amd/amdgpu/psp_funcs.h | 98 +++++<br>
> drivers/gpu/drm/amd/amdgpu/psp_ring.c | 354
++++++++++++++++<br>
> drivers/gpu/drm/amd/amdgpu/psp_ring.h | 43 ++<br>
> drivers/gpu/drm/amd/amdgpu/psp_tmr.c | 84 ++++<br>
> drivers/gpu/drm/amd/amdgpu/psp_tmr.h | 32 ++<br>
> drivers/gpu/drm/amd/amdgpu/psp_v10_0.c | 381
+----------------<br>
> drivers/gpu/drm/amd/amdgpu/psp_v11_0.c | 539
+-----------------------<br>
> drivers/gpu/drm/amd/amdgpu/psp_v3_1.c | 480
+--------------------<br>
> drivers/gpu/drm/amd/amdgpu/psp_xgmi.c | 207
+++++++++<br>
> drivers/gpu/drm/amd/amdgpu/psp_xgmi.h | 33 ++<br>
> drivers/gpu/drm/amd/amdgpu/soc15.c | 13 +-<br>
> 18 files changed, 1493 insertions(+), 1866
deletions(-)<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_asd.c<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_asd.h<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_cmn.c<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_cmn.h<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_funcs.h<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_ring.c<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_ring.h<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_tmr.c<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_tmr.h<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_xgmi.c<br>
> create mode 100644
drivers/gpu/drm/amd/amdgpu/psp_xgmi.h<br>
><br>
<br>
</div>
</span></font></div>
<br>
<fieldset class="mimeAttachmentHeader"></fieldset>
<pre class="moz-quote-pre" wrap="">_______________________________________________
amd-gfx mailing list
<a class="moz-txt-link-abbreviated" href="mailto:amd-gfx@lists.freedesktop.org">amd-gfx@lists.freedesktop.org</a>
<a class="moz-txt-link-freetext" href="https://lists.freedesktop.org/mailman/listinfo/amd-gfx">https://lists.freedesktop.org/mailman/listinfo/amd-gfx</a>
</pre>
</blockquote>
<br>
</body>
</html>