[avahi] Patch for gentoo compilation

Lennart Poettering mzzhgg at 0pointer.de
Thu Jun 30 05:55:32 PDT 2005

On Thu, 30.06.05 06:03, Steev (steev at steev.net) wrote:

> I am attaching the patch again (it applies cleanly against r154 as well
> as 153, until it gets committed to svn, its required to install create
> the proper init script as well as tell it where it should properly be.
> I am also attaching the new ebuild that I have, I used it to install,
> and aside from starting (takes too long to get a response) the only
> other issue I have is, it *appears* that /var/lib/run/avahi is hardcoded
> in /usr/bin/avahi (i ran strings /usr/bin/avahi | grep run) and on
> gentoo we don't use /var/lib/run, we use /var/run - not sure where to
> change this.  Although since I am just testing it out to make sure it
> works, I created /var/lib/run/avahi for it.

Have a look on the top of avahi-daemon/Makefile.am:


avahi puts its PID and socket files in AVAHI_RUNTIME_DIR. Ths should
be the place to fix this. However, our  autoconf guru, Sebastien,
might code up some neat autodetection routines for the right path for
the runtime directory. (And by while doing so moving the definition of
this path to configure.ac. What do you think, Sebastien?

Same thing in avahi-dnsconfd/Makefile.am. AVAHI_SOCKET is the socket
of avahi-daemon to connect to. AVAHI_RUNTIME_SCRIPT is the path where
to put the PID file. Since avahi-dns-confd puts its PID file directly
to /var/run/ (instead of /var/run/avahi/) this should be cleaned up a
little anyway.

> >> all this is good
> > 
> >> does avahi-discover works?
> avahi-discover "works" although, I don't get anything in my list at all.
>     I do have sshd running.

Yeah, you need to register a service on a some host on your network to
have avahi-discover show it up.

BTW: Sebastien, why did you ask this question? Doesn't it work on your
machine? Please post a bug report in that case!

> As I apparently cannot currently start avahi from the init script (oh,
> did I mention I am on dialup....) due to it taking too long to get a
> response, this is the output of me running avahi from the
> commandline.

Too long to get a response? To which query?

> mebius ~ # avahi
> Found user 'avahi' (UID 409) and group 'avahi' (GID 409).
> Successfully dropped root privileges.
> Enumeration complete
> Server startup complete.  Host name is <mebius.local.>
> iface.c: avahi_server_add_service() failed.

Hmm, seems you tried to register some kind of conflicting service record?


name { Lennart Poettering } loc { Hamburg - Germany }
mail { mzft (at) 0pointer (dot) de } gpg { 1A015CC4 }  
www { http://0pointer.de/lennart/ } icq# { 11060553 }

More information about the avahi mailing list