[avahi] Patch for gentoo compilation

Steev steev at steev.net
Thu Jun 30 09:40:56 PDT 2005

Hash: SHA1

Lennart Poettering wrote:
> On Thu, 30.06.05 06:03, Steev (steev at steev.net) wrote:
> Yeah, you need to register a service on a some host on your network to
> have avahi-discover show it up.

So it won't show up with anything on the localhost ?

>>As I apparently cannot currently start avahi from the init script (oh,
>>did I mention I am on dialup....) due to it taking too long to get a
>>response, this is the output of me running avahi from the
> Too long to get a response? To which query?

I believe this was actually because of the daemon refusing to start
because of /var/lib/run not existing.  I tried to find where portage
sets the localstatedir (it does set it to /var/lib) I got around this by
adding --localstatedir="/var" to the econf section in my ebuild. It now
starts fine (and after I had created /var/lib/run the init script worked
fine as well)

>>Server startup complete.  Host name is <mebius.local.>
>>iface.c: avahi_server_add_service() failed.
> Hmm, seems you tried to register some kind of conflicting service record?

I am not sure - I edited the example.service to only have the ssh part.

<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">

  <!-- $Id: example.service 125 2005-06-17 16:29:16Z lennart $ -->

  <name replace-wildcards="yes">Remote Terminal on %h</name>



That is my example.service file.  I am not sure what all else should go
in there, if anything.

> Lennart

- --
Steev Klimaszewski
steev at steev.net

Version: GnuPG v1.4.1 (GNU/Linux)


More information about the avahi mailing list