[avahi] Avahi and IPv6

W. Michael Petullo mike at flyn.org
Fri Dec 31 13:13:38 PST 2010

I have read several documents on the Internet that indicate that Avahi
supports IPv6. I am using Fedora 14 and am not getting the behavior I
expect from Avahi on IPv6.

I have written "use-ipv6=yes" to "avahi-daemon.conf," but when I run
"avahi-browse," I do not see any IPv6 services listed (only IPv4). For
an additional test, I turned off "use-ipv4." In this case, "avahi-browse"
listed no services. I would expect to see at least the "_workstation._tcp"
service listed as available on IPv6.

Finally, I enabled ipv6, disabled ipv4 and ran "avahi-publish -s test
_test._tcp 80."  This command responded with "Established under name
'test'," but avahi-browse did not display the service.

The Avahi daemon does seem to pick up my IPv6 interface, as the following
debug output shows:

$ sudo avahi-daemon --debug
Process 8620 died: No such process; trying to remove PID file. (/var/run/avahi-daemon//pid)
Found user 'avahi' (UID 498) and group 'avahi' (GID 493).
Successfully dropped root privileges.
avahi-daemon 0.6.27 starting up.
Successfully called chroot().
Successfully dropped remaining capabilities.
Loading service file /services/ssh.service.
Loading service file /services/udisks.service.
Joining mDNS multicast group on interface eth1.IPv6 with address fe80::225:ff:fe3f:e37e.
New relevant interface eth1.IPv6 for mDNS.
Joining mDNS multicast group on interface eth1.IPv4 with address
New relevant interface eth1.IPv4 for mDNS.
Network interface enumeration completed.
Registering new address record for fe80::225:ff:fe3f:e37e on eth1.*.
Registering new address record for on eth1.IPv4.
Registering HINFO record with values 'X86_64'/'LINUX'.
Server startup complete. Host name is imp.local. Local service cookie is 3709212864.
Service "imp" (/services/udisks.service) successfully established.
Service "imp" (/services/ssh.service) successfully established.

I have tried turning off my host firewall and have disabled SELinux.

Does anyone know why "avahi-browse" is not displaying IPv6 services?



More information about the avahi mailing list