[Beignet] [PATCH] Change %.20f to %e.

Yi Sun yi.sun at intel.com
Tue Feb 18 22:04:52 PST 2014


This can make the error information more readable.

Signed-off-by: Yi Sun <yi.sun at intel.com>

diff --git a/utests/utest_generator.py b/utests/utest_generator.py
index 626ac96..8d8eb3f 100644
--- a/utests/utest_generator.py
+++ b/utests/utest_generator.py
@@ -6,7 +6,7 @@ FLT_MIN_NEGA='-0x1.fffffep127f'
 FLT_MIN_POSI='0x1.0p-126f'
 FLT_MAX_NEGA='-0x1.0p-126f'
 
-paraTypeList={'float':'%.20f','int':'%d','double':'%lf','uint':'%d','string':'%s'}
+paraTypeList={'float':'%e','int':'%d','double':'%lf','uint':'%d','string':'%s'}
 
 
 def ulpUnit(ulpSize):
-- 
1.8.5.3



More information about the Beignet mailing list