[Beignet] [PATCH 1/3] correct the dst type to ud instead of uw for byte scattered read
Guo Yejun
yejun.guo at intel.com
Tue Feb 23 22:30:25 UTC 2016
the destination type is ud, not uw. Correct it to make the ASM more readable.
Signed-off-by: Guo Yejun <yejun.guo at intel.com>
---
backend/src/backend/gen_encoder.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/backend/src/backend/gen_encoder.cpp b/backend/src/backend/gen_encoder.cpp
index 9f9e420..31afa67 100644
--- a/backend/src/backend/gen_encoder.cpp
+++ b/backend/src/backend/gen_encoder.cpp
@@ -451,7 +451,7 @@ namespace gbe
this->setHeader(insn);
insn->header.destreg_or_condmod = GEN_SFID_DATAPORT_DATA;
- this->setDst(insn, GenRegister::uw16grf(dst.nr, 0));
+ this->setDst(insn, GenRegister::ud8grf(dst.nr, 0));
this->setSrc0(insn, GenRegister::ud8grf(src.nr, 0));
if (bti.file == GEN_IMMEDIATE_VALUE) {
--
1.9.1
More information about the Beignet
mailing list