[cairo-commit] cairo ChangeLog,1.474,1.475
Owen Taylor
commit at pdx.freedesktop.org
Thu Apr 7 11:04:02 PDT 2005
- Previous message: [cairo-commit] cairo/src cairo-atsui-font.c, 1.6,
1.7 cairo-ft-font.c, 1.52, 1.53 cairo-gstate.c, 1.102,
1.103 cairo-image-surface.c, 1.33, 1.34 cairo-matrix.c, 1.21,
1.22 cairo-pattern.c, 1.28, 1.29 cairo-pdf-surface.c, 1.24,
1.25 cairo-pen.c, 1.22, 1.23 cairo-surface.c, 1.51,
1.52 cairo-win32-font.c, 1.11, 1.12 cairo-xlib-surface.c, 1.55,
1.56 cairo.c, 1.71, 1.72 cairo.h, 1.91, 1.92 cairoint.h, 1.117,
1.118
- Next message: [cairo-commit] cairo/doc/public cairo-sections.txt,1.9,1.10
- Messages sorted by:
[ date ]
[ thread ]
[ subject ]
[ author ]
Committed by: otaylor
Update of /cvs/cairo/cairo
In directory gabe:/tmp/cvs-serv7423
Modified Files:
ChangeLog
Log Message:
2005-04-06 Owen Taylor <otaylor at redhat.com>
* src/cairo.h src/cairo-gstate.c src/cairo-font.c: Add
a cairo_font_face_t type to hold a description of a font
face. Replace cairo_set_font() with cairo_set_font_face().
* src/cairoint.h src/cairo-font.c src/cairo-gstate.c: Add
"cairo_simple_font_face" for family/weight/slant and use
it to implement font naming for the toy API.
* src/cairo-ft.h src/cairo-ft-font.c cairo-win32.h
cairo-win32-font.c: Switch the FreeType and Win32 backends
over to using cairo_font_face_t.
* src/cairo.h src/cairo-font.c src/cairo-ft-font.c
src/cairo-win32-font.c: Pass in font matrix and CTM separately
rather than as a composite scale when creating fonts; allows
removing font_matrix argument to metrics functions.
* src/cairoint.h src/cairo-font.c src/cairo-ft-font.c
src/cairo-win32-font.c: Remove cairo_font_scale_t type,
just use cairo_matrix_t and ignore translations.
* src/cairo-ft.h src/cairo-ft-font.c: Remove
cairo_ft_font_get_pattern() -- it can't work for all FreeType
backend fonts and doesn't seem particularly useful.
* src/cairo.[ch]: Rename cairo_font_get_extents() to
cairo_font_extents()
* doc/public/cairo-sections.txt: Update, split font functions
into a separate section.
* src/cairo-ft-font.c (_ft_unscaled_font_get_for_pattern): Fix
locking order problem.
* src/cairo-font.c: Add caches for simple font faces and from
cairo_font_face_t to cairo_scaled_font_t.
* src/cairo.h src/cairoint.h src/cairo-font.c src/cairo-win32-font.c
src/cairo-ft-font.c src/cairo-gstate.c src/cairo-gstate-private.h:
Rename cairo_font_t to cairo_scaled_font_t.
Index: ChangeLog
===================================================================
RCS file: /cvs/cairo/cairo/ChangeLog,v
retrieving revision 1.474
retrieving revision 1.475
diff -u -d -r1.474 -r1.475
--- ChangeLog 7 Apr 2005 17:01:49 -0000 1.474
+++ ChangeLog 7 Apr 2005 18:03:59 -0000 1.475
@@ -1,3 +1,46 @@
+2005-04-06 Owen Taylor <otaylor at redhat.com>
+
+ * src/cairo.h src/cairo-gstate.c src/cairo-font.c: Add
+ a cairo_font_face_t type to hold a description of a font
+ face. Replace cairo_set_font() with cairo_set_font_face().
+
+ * src/cairoint.h src/cairo-font.c src/cairo-gstate.c: Add
+ "cairo_simple_font_face" for family/weight/slant and use
+ it to implement font naming for the toy API.
+
+ * src/cairo-ft.h src/cairo-ft-font.c cairo-win32.h
+ cairo-win32-font.c: Switch the FreeType and Win32 backends
+ over to using cairo_font_face_t.
+
+ * src/cairo.h src/cairo-font.c src/cairo-ft-font.c
+ src/cairo-win32-font.c: Pass in font matrix and CTM separately
+ rather than as a composite scale when creating fonts; allows
+ removing font_matrix argument to metrics functions.
+
+ * src/cairoint.h src/cairo-font.c src/cairo-ft-font.c
+ src/cairo-win32-font.c: Remove cairo_font_scale_t type,
+ just use cairo_matrix_t and ignore translations.
+
+ * src/cairo-ft.h src/cairo-ft-font.c: Remove
+ cairo_ft_font_get_pattern() -- it can't work for all FreeType
+ backend fonts and doesn't seem particularly useful.
+
+ * src/cairo.[ch]: Rename cairo_font_get_extents() to
+ cairo_font_extents()
+
+ * doc/public/cairo-sections.txt: Update, split font functions
+ into a separate section.
+
+ * src/cairo-ft-font.c (_ft_unscaled_font_get_for_pattern): Fix
+ locking order problem.
+
+ * src/cairo-font.c: Add caches for simple font faces and from
+ cairo_font_face_t to cairo_scaled_font_t.
+
+ * src/cairo.h src/cairoint.h src/cairo-font.c src/cairo-win32-font.c
+ src/cairo-ft-font.c src/cairo-gstate.c src/cairo-gstate-private.h:
+ Rename cairo_font_t to cairo_scaled_font_t.
+
2005-04-06 Carl Worth <cworth at cworth.org>
* src/cairo.h: Rework the cairo_matrix_t interface in several ways.
- Previous message: [cairo-commit] cairo/src cairo-atsui-font.c, 1.6,
1.7 cairo-ft-font.c, 1.52, 1.53 cairo-gstate.c, 1.102,
1.103 cairo-image-surface.c, 1.33, 1.34 cairo-matrix.c, 1.21,
1.22 cairo-pattern.c, 1.28, 1.29 cairo-pdf-surface.c, 1.24,
1.25 cairo-pen.c, 1.22, 1.23 cairo-surface.c, 1.51,
1.52 cairo-win32-font.c, 1.11, 1.12 cairo-xlib-surface.c, 1.55,
1.56 cairo.c, 1.71, 1.72 cairo.h, 1.91, 1.92 cairoint.h, 1.117,
1.118
- Next message: [cairo-commit] cairo/doc/public cairo-sections.txt,1.9,1.10
- Messages sorted by:
[ date ]
[ thread ]
[ subject ]
[ author ]
More information about the cairo-commit
mailing list