[cairo-commit] cairo ChangeLog,1.449,1.450
Carl Worth
commit at pdx.freedesktop.org
Wed Mar 23 13:52:57 PST 2005
- Previous message: [cairo-commit]
cairo/src cairo-path-data-private.h, 1.2, 1.3 cairo.c,
1.63, 1.64 cairoint.h, 1.110, 1.111
- Next message: [cairo-commit] cairo/src cairo-gstate-private.h, 1.1,
1.2 cairo-path-fixed-private.h, 1.1, 1.2 cairo_font.c, 1.37,
1.38 cairo_ft_font.c, 1.47, 1.48 cairo_gstate.c, 1.96,
1.97 cairo_path.c, 1.22, 1.23 cairo_path_bounds.c, 1.16,
1.17 cairo_path_fill.c, 1.16, 1.17 cairo_path_stroke.c, 1.22,
1.23 cairoint.h, 1.111, 1.112
- Messages sorted by:
[ date ]
[ thread ]
[ subject ]
[ author ]
Committed by: cworth
Update of /cvs/cairo/cairo
In directory gabe:/tmp/cvs-serv12778
Modified Files:
ChangeLog
Log Message:
* src/cairo_path.c: (_cairo_path_fixed_init),
(_cairo_path_fixed_init_copy), (_cairo_path_fixed_fini),
(_cairo_path_fixed_move_to), (_cairo_path_fixed_rel_move_to),
(_cairo_path_fixed_line_to), (_cairo_path_fixed_rel_line_to),
(_cairo_path_fixed_curve_to), (_cairo_path_fixed_rel_curve_to),
(_cairo_path_fixed_close_path),
(_cairo_path_fixed_get_current_point), (_cairo_path_add),
(_cairo_path_add_op_buf), (_cairo_path_new_op_buf),
(_cairo_path_add_arg_buf), (_cairo_path_new_arg_buf),
(_cairo_path_fixed_interpret):
* src/cairo_path_bounds.c: (_cairo_path_fixed_bounds):
* src/cairo_path_fill.c: (_cairo_path_fixed_fill_to_traps):
* src/cairo_path_stroke.c: (_cairo_path_fixed_stroke_to_traps):
* src/cairoint.h: Rename cairo_path_real_t to cairo_path_fixed_t
and fix all _cairo_path functions to be named as _cairo_path_fixed
functions.
* src/cairo-gstate-private.h:
* src/cairo-path-fixed-private.h:
* src/cairo_font.c: (_cairo_font_glyph_path):
* src/cairo_ft_font.c: (_move_to), (_line_to), (_conic_to),
(_cubic_to), (_cairo_ft_font_glyph_path):
* src/cairo_gstate.c: (_cairo_gstate_init),
(_cairo_gstate_init_copy), (_cairo_gstate_fini),
(_cairo_gstate_new_path), (_cairo_gstate_move_to),
(_cairo_gstate_line_to), (_cairo_gstate_curve_to),
(_cairo_gstate_rel_move_to), (_cairo_gstate_rel_line_to),
(_cairo_gstate_rel_curve_to), (_cairo_gstate_close_path),
(_cairo_gstate_get_current_point), (_cairo_gstate_interpret_path),
(_cairo_gstate_stroke), (_cairo_gstate_in_stroke),
(_cairo_gstate_fill), (_cairo_gstate_in_fill),
(_cairo_gstate_stroke_extents), (_cairo_gstate_fill_extents),
(_cairo_gstate_clip), (_cairo_gstate_text_to_glyphs): Track name
change of cairo_path_real_t and _cairo_path_fixed functions.
Index: ChangeLog
===================================================================
RCS file: /cvs/cairo/cairo/ChangeLog,v
retrieving revision 1.449
retrieving revision 1.450
diff -u -d -r1.449 -r1.450
--- ChangeLog 23 Mar 2005 21:52:11 -0000 1.449
+++ ChangeLog 23 Mar 2005 21:52:54 -0000 1.450
@@ -1,5 +1,42 @@
2005-03-23 Carl Worth <cworth at cworth.org>
+ * src/cairo_path.c: (_cairo_path_fixed_init),
+ (_cairo_path_fixed_init_copy), (_cairo_path_fixed_fini),
+ (_cairo_path_fixed_move_to), (_cairo_path_fixed_rel_move_to),
+ (_cairo_path_fixed_line_to), (_cairo_path_fixed_rel_line_to),
+ (_cairo_path_fixed_curve_to), (_cairo_path_fixed_rel_curve_to),
+ (_cairo_path_fixed_close_path),
+ (_cairo_path_fixed_get_current_point), (_cairo_path_add),
+ (_cairo_path_add_op_buf), (_cairo_path_new_op_buf),
+ (_cairo_path_add_arg_buf), (_cairo_path_new_arg_buf),
+ (_cairo_path_fixed_interpret):
+ * src/cairo_path_bounds.c: (_cairo_path_fixed_bounds):
+ * src/cairo_path_fill.c: (_cairo_path_fixed_fill_to_traps):
+ * src/cairo_path_stroke.c: (_cairo_path_fixed_stroke_to_traps):
+ * src/cairoint.h: Rename cairo_path_real_t to cairo_path_fixed_t
+ and fix all _cairo_path functions to be named as _cairo_path_fixed
+ functions.
+
+ * src/cairo-gstate-private.h:
+ * src/cairo-path-fixed-private.h:
+ * src/cairo_font.c: (_cairo_font_glyph_path):
+ * src/cairo_ft_font.c: (_move_to), (_line_to), (_conic_to),
+ (_cubic_to), (_cairo_ft_font_glyph_path):
+ * src/cairo_gstate.c: (_cairo_gstate_init),
+ (_cairo_gstate_init_copy), (_cairo_gstate_fini),
+ (_cairo_gstate_new_path), (_cairo_gstate_move_to),
+ (_cairo_gstate_line_to), (_cairo_gstate_curve_to),
+ (_cairo_gstate_rel_move_to), (_cairo_gstate_rel_line_to),
+ (_cairo_gstate_rel_curve_to), (_cairo_gstate_close_path),
+ (_cairo_gstate_get_current_point), (_cairo_gstate_interpret_path),
+ (_cairo_gstate_stroke), (_cairo_gstate_in_stroke),
+ (_cairo_gstate_fill), (_cairo_gstate_in_fill),
+ (_cairo_gstate_stroke_extents), (_cairo_gstate_fill_extents),
+ (_cairo_gstate_clip), (_cairo_gstate_text_to_glyphs): Track name
+ change of cairo_path_real_t and _cairo_path_fixed functions.
+
+2005-03-23 Carl Worth <cworth at cworth.org>
+
* src/cairo-path-data-private.h: Remove CAIRO_BEGIN_DECLS and
CAIRO_END_DECLS as they are not needed for private headers.
- Previous message: [cairo-commit]
cairo/src cairo-path-data-private.h, 1.2, 1.3 cairo.c,
1.63, 1.64 cairoint.h, 1.110, 1.111
- Next message: [cairo-commit] cairo/src cairo-gstate-private.h, 1.1,
1.2 cairo-path-fixed-private.h, 1.1, 1.2 cairo_font.c, 1.37,
1.38 cairo_ft_font.c, 1.47, 1.48 cairo_gstate.c, 1.96,
1.97 cairo_path.c, 1.22, 1.23 cairo_path_bounds.c, 1.16,
1.17 cairo_path_fill.c, 1.16, 1.17 cairo_path_stroke.c, 1.22,
1.23 cairoint.h, 1.111, 1.112
- Messages sorted by:
[ date ]
[ thread ]
[ subject ]
[ author ]
More information about the cairo-commit
mailing list