[cairo-commit] Changes to 'refs/tags/1.4.2'
Carl Worth
cworth at kemper.freedesktop.org
Mon Mar 19 23:58:44 PDT 2007
Tag '1.4.2' created by Carl Worth <cworth at cworth.org> at 2007-03-20 07:56 -0700
cairo 1.4.2 release
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)
iD8DBQBF/4Wj6JDdNq8qSWgRAlsUAJwK2sQRmxqvonqEyTneya11JnAA2QCghJoT
cAHWir/DdaTxBrZJBOy3jhY=
=hxHR
-----END PGP SIGNATURE-----
Changes since 1.4.0:
Adrian Johnson:
PDF: Set page group color space to DeviceRGB
Fix buffer overflow warning
Fix incorrect file permission in previous commit
Behdad Esfahbod:
Remove extra word in docs
[configure.in] Remove AM_MAINTAINER_MODE
[cosmetic] Remove static var from testing code in bentley-ottman.
[Type1] Add cairo-type1-private.h that Type1 fallback and subset code share
[cairoint] Move endian-conversion routines into cairoint.h
[PS/PDF/SVG] Rename internal symbols to have _cairo_*_surface prefix
[glitz] Mark some constant static structures as const
[directfb,os2] #error if the backend is not compiled in, like others do
[boilerplate] Prefer top_builddir to top_srcdir
[cairo-path-fixed] Avoid malloc for small paths
[cairo-path-fixed] Merge op and arg bufs
[cairo-path-fixed] Fine-tune size of buffer
[cairo_t] Move gstate pointer before cairo_path_fixed_t for better cache behavior
[Quartz] Don't include cairo-private.h
[cairo_t] Make path an array of size one
[cairo-clip] Make _cairo_clip_init tolerate NULL target
[cairo_t] Embed a gstate into cairo_t
[skiplist] Move static variable out of function
[test-surfaces] Prefix public symbols with _cairo
[skiplist] Prefix symbols with _cairo
[test] Make pdiff if necessary
[cairo-traps] Use INT32_MIN/MAX instead of INT16_MIN/MAX << 16
[cairo-traps] Clean-up realloc algorithm for clarity
[cairo-traps] Add a cache of one trapezoid to cairo_traps_t
[cairo_traps_t] Reorder struct members for clarity
[cairo-spline] Clean-up realloc algorithm for clarity
[cairo-spline] Add a cache of eight points to cairo_spline_t
[cairo-slope] Make comparison stable if both vectors are zero
[cairo-polygon] Clean-up realloc algorithm for clarity
[cairo_polygon_t] Reorder struct members for clarity
[cairo_polygon_t] Remove unused member 'closed'
[cairo_polygon_t] Change has_current_point from int to cairo_bool_t
[cairo-spline] Fix typo in comment
[cairo-polygon] Add a cache of eight edges to cairo_polygon_t
[polygon,spline,traps] Avoid free(NULL)
[cairo-pattern] Add XXX note
[cairo-pattern] Fix color conversion from short to double
[cairo-color] Add cairo-private _cairo_color_double_to_short()
[cairo-pattern] Use _cairo_color_double_to_short() to fix color conversion
[test] In pattern-getters test, log what went wrong
[test] If backends are limited and all untested, pass the test
[Makefile.am] Do not distribute cairo-features.h, Ouch!
[cairo-pattern] Grow color-stops array exponentially
[cairo-pattern] Add a cache of two color stops to cairo_gradient_pattern_t
[win32] Fix font descent computation
[win32] Really return unhinted font metrics if metrics hinting is off
[boilerplate] Don't build in make all
Brian Ewins:
[quartz] rename remaining nquartz symbols to quartz.
[atsui] clean up warnings
[atsui] remove the unused old_show_glyphs function.
[atsui] refactor CreateSizedCopyOfStyle
[atsui] store sizes in the atsui font
[atsui] make text_to_glyphs return positions in user units. (#9568)
[quartz] apply ctm to text (#9568)
Carl Worth:
Increment version to 1.4.1 after making the 1.4.0 release
Fix a LOCK vs. UNLOCK typo, (yes, I'm that stupid).
perf/README: Add notes on using cairo-perf-diff
Remove radial-gradient test from XFAIL list
Add new skew-extreme test case.
Fix bugs in _cairo_traps_tessellate_convex_quad
Remove dead-code remnants of old tessellator
check-def.sh: Adjust test to exempt _cairo_test_* functions as well as _cairo_*_test_*
Add svg-specific reference image for radial-gradient test.
Fix _cairo_traps_tessellate_convex_quad to handle a == b
Implement _cairo_traps_tessellate_triangle with _cairo_traps_tessellate_convex_quad
Add line-width-zero test which currently crashes.
Fix cairo_stroke_extents and cairo_in_stroke to not crash with line width of 0.0
Allow NULL pointers for functions that accept pointers for multiple return values.
Make compilation of cairo-deflate-stream.c conditional on compilation of PDF backend.
Avoid pulling in -lz for the ps backend.
XCB: Fix parameter-order confusion with xcb_create_pixmap
xlib: Prefer surface->format over surface->visual for identifying masks
Propagate a nil surface out of _cairo_surface_create_similar_scratch
Temporarily remove extend-reflect from the list of tests.
NEWS: Add notes for cairo 1.4.2
Increment cairo version to 1.4.2 (and libtool versioning to 13:1:11)
Add skew-extreme-ref.png to the tar file for the release.
boilerplate: Add EXTRA_LTLIBRARIES to CLEANFILES to allow make distcleancheck to pass.
Chris Wilson:
Add valgrind/callgrind targets to Makefile.
Fix up the trivial leaks found by valgrind.
Avoid the struct copy when source and destination are the same.
Correct an off-by-one in the reflection of the convolution index.
Introduce hooks for _cairo_xlib_close_display()
Privately export a function to reset the scaled font's glyph caches.
Clear the XRender data on display closure.
Emmanuel Pacaud:
SVG: Fix CAIRO_EXTEND_REFLECT for radial gradients.
SVG: fix a radial gradient failure when using CAIRO_EXTEND_REFLECT.
Gilles Dauphin:
Don't use unsupported visibily attribute hidden on Solaris
Mathias Hasselmann:
Improve CPU utilization when building cairo-perf
Transform the output of cairo-perf-diff into HTML
Add index.html to .gitignore
Include pixman/src in cairo-perf hash
[cairo-perf-diff] Update usage screen to mention --html.
[cairo-perf] Emit warning, if cairo-perf is not CPU bound
Thomas Klausner:
Use "find !" rather than "find -not" for better portability
---
NEWS | 130 ++++++++
RELEASING | 2
boilerplate/Makefile.am | 8
boilerplate/cairo-boilerplate.c | 6
configure.in | 23 -
doc/public/Headers.mk | 1
doc/public/Makefile.am | 1
perf/.gitignore | 1
perf/Makefile.am | 26 +
perf/README | 111 ++++++
perf/cairo-perf-diff | 107 ++++--
perf/cairo-perf.c | 56 +++
perf/make-html.py | 89 +++++
pixman/src/pixman.h | 2
src/Makefile.am | 12
src/cairo-atsui-font.c | 233 +++-----------
src/cairo-bentley-ottmann.c | 26 -
src/cairo-cff-subset.c | 28 -
src/cairo-clip.c | 5
src/cairo-color.c | 11
src/cairo-directfb.h | 3
src/cairo-ft-font.c | 2
src/cairo-glitz-surface.c | 8
src/cairo-gstate.c | 96 ++----
src/cairo-os2.h | 2
src/cairo-path-fill.c | 51 +--
src/cairo-path-fixed-private.h | 28 -
src/cairo-path-fixed.c | 303 ++++++------------
src/cairo-pattern.c | 91 ++++-
src/cairo-pdf-surface.c | 83 ++---
src/cairo-polygon.c | 48 +--
src/cairo-private.h | 5
src/cairo-ps-surface.c | 52 +--
src/cairo-quartz-private.h | 6
src/cairo-quartz-surface.c | 248 +++++++--------
src/cairo-scaled-font.c | 9
src/cairo-skiplist-private.h | 22 -
src/cairo-skiplist.c | 35 +-
src/cairo-slope.c | 8
src/cairo-spline.c | 39 +-
src/cairo-surface.c | 14
src/cairo-svg-surface.c | 465 +++++++++++++++++++++--------
src/cairo-traps.c | 623 ++++++---------------------------------
src/cairo-truetype-subset.c | 39 --
src/cairo-type1-fallback.c | 14
src/cairo-type1-private.h | 45 ++
src/cairo-type1-subset.c | 18 -
src/cairo-win32-font.c | 4
src/cairo-xcb-surface.c | 7
src/cairo-xlib-private.h | 15
src/cairo-xlib-screen.c | 153 +++++++--
src/cairo-xlib-surface.c | 52 ++-
src/cairo.c | 89 ++---
src/cairo.h | 2
src/cairoint.h | 77 +++-
src/check-def.sh | 2
src/check-headers.sh | 2
src/test-fallback-surface.c | 8
src/test-fallback-surface.h | 2
src/test-meta-surface.c | 2
src/test-meta-surface.h | 2
src/test-paginated-surface.c | 2
src/test-paginated-surface.h | 2
test/.gitignore | 2
test/Makefile.am | 8
test/cairo-test.c | 44 +-
test/line-width-zero.c | 79 ++++
test/pattern-getters.c | 14
test/pdiff/lpyramid.c | 4
test/radial-gradient-svg-ref.png |binary
test/radial-gradient.c | 3
test/skew-extreme-ref.png |binary
test/skew-extreme.c | 126 +++++++
73 files changed, 2214 insertions(+), 1722 deletions(-)
---
More information about the cairo-commit
mailing list