[Xr] Xr API comments

Soorya Kuloor skuloor at verano.com
Fri May 23 12:54:19 PDT 2003


After using the Xr API for a while, here are some thoughts:

* XrSave() and XrRestore() function names are a bit confusing. XrPush()
and XrPop() may be better names?. Other libraries seem to use the
push/pop names (Eclipse draw2d, Java2D).

* Are there any plans to provide 'higher level' shape related functions
in Xr API, such as drawing ellipses, curves and rectangles? I am
specifically talking about shapes that are supported by SVG, such as
arcs, ellipses, rounded rectangles. Xr already has 'path'. I had to dig
them out of libxsvg and copy them over into my code. Some of the shapes
such as arcs are really complex. It would be a lot of help if Xr
provided functions for this. This would also save time for people
developing higher level libraries on top of Xr.

-- Soorya

More information about the cairo mailing list