[cairo] cairo for debian

Dave Beckett dave.beckett at bristol.ac.uk
Fri Jan 16 14:47:21 PST 2004

On Fri, 16 Jan 2004 14:21:24 -0800
Bob Pappas <bpappas at macromedia.com> wrote:

> Hi,
> I'm trying to get cairo running for Mono. I've started with the Dave
> Beckett packages. However I'm getting a shared library runtime error
> for libic.so.1 which is obsolete. 

What error exactly?

I've got the CVS mono compiled against the built debian cairo packages
and working just fine; it uses pkgconfig to get the right cairo libs and
does not go near libic.  This is on debian unstable.

What is trying to link with libic?

> I've tried to build libic.so from
> CVS, but get a config problem: "aclocal: configure.in: 36: macro
> 'AM_PROG_LIBTOOL' not found in library"

Sounds like an inconsistent autoconf/automake/aclocal mess not to
do with cairo.

Please don't try building the obsolete libic.
> I then have tried to build libpixman from CVS and get the same
> problem.

You'll have to give some more precise information.  However
it sounds like at the very least you need to check the toolchain
is working.


More information about the cairo mailing list