[cairo] gcc warnings issue
behdad at cs.toronto.edu
Tue Aug 9 10:16:55 PDT 2005
On Tue, 9 Aug 2005, Carl Worth wrote:
> > clear_, index_, rand_, time_, link_, y1_
> Seems like as good a plan as any. The fact that POSIX and C99 math.h
> have functions named y0 and y1 seems like real brain damage to
> me. Worse, implementations with y0 and y1 _macros_ would still be
> Is it sufficient to just do this in cairo.h as in the attached patch?
I suggest using capital letters instead: X0, Y0, X1, Y1, X2, Y2.
A quick grep suggests that an automatic replace does the job.
> I can live with that workaround since the names there have almost no
> impact on the implementation of cairo itself nor on applications using
> I would find it hard to get excited about bubbling the extra
> underscores down throughout the entire implementation.
More information about the cairo