[cairo] "operator" keyword in libcairo

Hans Breuer hans at breuer.org
Wed Jan 19 12:58:21 PST 2005


Carl Worth wrote:
> On Wed, 19 Jan 2005 10:33:12 -0500, Owen Taylor wrote:
> 
>>>But "operator" really is the right word, (both mathematically and from
>>>following the Porter/Duff paper).
>>
>>Remember, it's only the header files. You can call the parameter
>>different things in the source files and the headers if you want.
> 
> 
> Yeah, that's what we did with the prototypes in cairo.h, and I almost
> committed the same thing for cairoint.h this morning, but I ran into
> the following:
> 
> 	typedef struct _cairo_gstate {
> 	    cairo_operator_t operator;
> 	    /* ... */
> 	}
> 
> Any suggestion for that one?
> 
My recent patch had that :

+#ifdef __cplusplus
+    /* ugly, but restricts required changes to this header --hb */
+    cairo_operator_t _operator;
+#else
      cairo_operator_t operator;
+#endif


-------- Hans "at" Breuer "dot" Org -----------
Tell me what you need, and I'll tell you how to
get along without it.                -- Dilbert



More information about the cairo mailing list