[cairo] API Shakeup: cairo_current_path -> cairo_copy_path_data

Carl Worth cworth at cworth.org
Wed Mar 16 14:13:23 PST 2005


On Mon, 14 Mar 2005 21:15:56 -0800, Bill Spitzak wrote:
> I'm wondering if instead the structure should be:
> 
> typedef union {
>    struct {
>      enum {
>        ...
>      } type;
>      int length;
>    } header;
>    double value;
> } cairo_path_data_t;

You can find something much like that in Keith's original proposal
near the top of this thread. In discussion, we decided that code like:

	x1 = p[1].value;
	y1 = p[2].value;
	x2 = p[3].value;
	y2 = p[4].value;
	x3 = p[5].value;
	y3 = p[6].value;

was too messy to make the space savings worth it.

-Carl
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/cairo/attachments/20050316/3357616c/attachment.pgp


More information about the cairo mailing list