[cairo] compiling cairo on Solaris 9 Sparc

Schmid, Wolfgang W.Schmid at t-systems.com
Wed Aug 8 07:14:03 PDT 2007

Hello list,

I tried to compile librsvg from source because there are no precompiled
packages for Sparc Solaris.
librsvg is dependent on pango, cairo, pangocairo, etc.
There is a precompiled package for pango but not for cairo and

Now I tried to compile cairo first.

The output of 'configure' says there's a missing package 'x11'.
This is true, no 'x11.pc' package description file is found in any of 
the pkgconfig directories on the system.

What is the real name of the Package and where can I get the source?
Is this a linux specific package?

Did ever anyone compile cairo on Sparc Solaris?

This is the output from configure:
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for X... libraries /usr/openwin/lib, headers
checking for cairo's Xlib backend... 
checking for xlib... Package x11 was not found in the pkg-config search
Perhaps you should add the directory containing `x11.pc'
to the PKG_CONFIG_PATH environment variable
No package 'x11' found
checking whether -R must be followed by a space... no
checking for gethostbyname... no
checking for gethostbyname in -lnsl... yes
checking for connect... no
checking for connect in -lsocket... yes

Thanks for your hints and help

-- Wolfgang (w.schmid  at t - systems.com)

More information about the cairo mailing list