[cairo] pangocairo misbehaves on Mac OS X 10.5 (using Quartz/ATSUI, no Xlibs)

Alex Shulgin alexander.shulgin at yessoftware.com
Mon Dec 14 09:06:58 PST 2009

Andrea Canciani wrote:
> On Fri, Dec 11, 2009 at 3:32 PM, Alex Shulgin
> <alexander.shulgin at yessoftware.com> wrote:
>> Andrea Canciani wrote:
>>> On Thu, Dec 10, 2009 at 1:35 PM, Alex Shulgin
>>> <alexander.shulgin at yessoftware.com> wrote:
>>>> Alex Shulgin wrote:
>>>>> Hi,
>>>>> I have this really simple test program which is using pangocairo to
>>>>> render some text in an image surface.  And it crashes constantly on Mac
>>>>> OS X 10.5.8.
>>>> BUMP!  Anyone?
>>> It might be related to some other quartz-font bugs:
>>> http://bugs.freedesktop.org/show_bug.cgi?id=24862
>>> http://bugs.freedesktop.org/show_bug.cgi?id=22199
>>> I didn't have time to work on them yet, but I've been unable to
>>> reproduce them with git master.
>>> I'll check if they happen in my environment with an older cairo asap.
>>> In the meantime, could you please confirm that this problem only
>>> occurs when using the quartz-font backend?
>> Just checked: it doesn't crash when built w/o quartz-font support.
>> Please let me know how can I help in debugging this further.

> Would it be possible for you to test your program on cairo 1.9.4?
> I can reproduce the bugs I linked above on 1.8.8 but they are not
> present in 1.9.4

OK, I've tried it with 1.9.4 and it crashed in exactly the same manner 
(only line numbers in the backtrace are different).

I've also tried recompiling pixman, cairo-1.9.4 and pango with 
CFLAGS=-O0 and the results are the same.

What do I do?  Should I try different version of gcc?


More information about the cairo mailing list