[cairo] Jasper dependency?

Dan Ventura dventura7 at gmail.com
Thu Feb 5 22:49:12 PST 2009

I recently switched from a ppc Mac to an Intel Mac.  I've been cobbling
together distros dodging the architecture issues to get cairo to run (which
worked great using Macports).  However, I recently ran into more -- my
ImageMagick install was out of whack.  So, I did a complete wipe of the
/opt/local dir and reinstalled Macports from scratch, re-installed Cairo,
installed ImageMagick and everything installed fine.

The funny thing is that a cairo-based app that had been working fine now
will not build due to the following link error

 ld: library not found for -ljasper-1.701.1.0.0

I did have this version of Jasper in my old dir tree, and the app built just
fine before my reinstall of Macports, Cairo and ImageMagick.  I've just
installed the latest version of Jasper 1.900.x, but still no luck compiling.
 So, two questions:

1. Does Cairo depend on Jasper (and if so, why didn't it get
installed/updated/whatever on the re-install of cairo?

2. Why is my linker looking for the old version of Jasper when I've just
barely installed (what I assume is the latest version of cairo with

3. How do I get my project to build now?

I guess that's three questions, but any help will be appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.cairographics.org/archives/cairo/attachments/20090205/e90995b7/attachment.html 

More information about the cairo mailing list