[cairo] Polygon clipping problem

M Joonas Pihlaja jpihlaja at cc.helsinki.fi
Thu Feb 12 13:53:28 PST 2009


On Thu, 12 Feb 2009, cu wrote:

[snip code]

> When values of x1 and/or y1 are over specific limit (setting one of the
> two values to 40000000 does the trick), the surface is not properly
> filled. Instead, it either has a narrow filled band or is empty (if one
> of the device_offset functions is uncommented). As values decrease
> towards about 35M progressively more of the surface would be filled.

I can't reproduce this problem using the code snippet you gave using 
cairo-1.6.4 or the current development cairo, when running on Debian 
testing.  For concreteness, I ran the program at 
http://pastey.net/108202 as "./big-fill 35e6 35e6", "./big-fill 40e6 
40e6" and got a totally red output out-big-fill.png both times.

> Is this an expected behavior? It would seem that although large, the
> numbers are not near the limit of even 32 bit integer (and certainly not
> double)?

It's not expected behaviour. :)  If you could test with the latest 
stable release cairo 1.8.6 and find it still doesn't work for you, 
it'd be best to file a bug with specifics and a test case at




More information about the cairo mailing list