[cairo] Cairo with OpenGLES

Alexandros Frantzis alexandros.frantzis at linaro.org
Mon Jul 25 05:16:45 PDT 2011

On Mon, Jul 25, 2011 at 11:01:42AM +0200, Singh Khurdiya Vijay (CM-AI/EAR) wrote:
> Thanks...Now it build's.
> Initially I was also trying with only gles2 but I was getting some error from header & once I enabled gl I was not getting same error from header so I thought enable-gl also required.
> Once u confirmed I tried to check header properly & found gles2 header was not proper & after changing header I got error solved..
> As I mentioned earlier if anyone have test case to  test gles2 then please share the same.

One idea is to use the cairo test suite (use test target 'egl').

If you need a simple sample application, I have ported cairogears to gles2. Get it from:


This is actually a debian source package with patches already applied to
the tree, but you can just treat it as a normal source tarball. To see
what changes have been applied look in debian/patches/*.

To build with GLX or GLES2 support use Makefile.glx or Makefile.es2 respectively.
(or use it as a base to create your own if cairo with gl/gles2 support is
not installed system-wide).

Depending on the kind of build, the '-gl' command line option will use cairo-gl
or cairo-gles2.


More information about the cairo mailing list