[cairo] i386

Oli Larkin olilarkin at googlemail.com
Sun Dec 23 02:49:09 PST 2012

On 23 Dec 2012, at 02:38, Ryan Schmidt wrote:

> On Dec 21, 2012, at 07:49, Oli Larkin wrote:
>> thanks ryan. that worked
> Just to clarify.... did this work:
> CFLAGS="-arch i386" CXXFLAGS="-arch i386" LDFLAGS="-arch i386" ./configure

yes... i did this once of i386 and once for x86_64 and used lipo to join the libraries

> Or did you try building for multiple architectures simultaneously:
> CFLAGS="-arch i386 -arch x86_64" CXXFLAGS="-arch i386 -arch x86_64" LDFLAGS="-arch i386 -arch x86_64" ./configure

just tried it and I got the following error

  CC     cairo-analysis-surface.lo
gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags
make[3]: *** [cairo-analysis-surface.lo] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

> If the latter now works, that would be good to know.


More information about the cairo mailing list