[cairo] build failed

UtG erolele at gmail.com
Thu Feb 20 04:07:28 CET 2014

suzuki toshiya <mpsuzuki <at> hiroshima-u.ac.jp> writes:

> Ahhhhhh, please try PKG_CONFIG_LIBDIR, instead of PKG_CONFIG_PATH.
> Please consider "man pkg-config", you will understand that
> * the directories specified by PKG_CONFIG_PATH are searched
> AFTER the search in the default (in this case, amd64) directories.
> * PKG_CONFIG_LIBDIR replaces the default directory, thus,
> amd64 directories would not be searched.
> I'm quite sorry for that I could not give this info
> immediately, in spite of your first message stating
> that you used PKG_CONFIG_PATH already.
> Regards,
> mpsuzuki

I tried in this way:

    build() {
    export CC="gcc -m32"
    export CXX="g++ -m32"
    export PKG_CONFIG_LIBDIR="/usr/lib32/pkgconfig"


export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"

but the build failed again (this time with a different error):

In file included from cairo-xlib-xrender.h:45:0,
                 from cairo-xlib-xrender-private.h:53,
                 from cairo-xlib-private.h:41,
                 from cairo-xlib-core-compositor.c:51:
/usr/include/X11/extensions/Xrender.h:199:3: note: previous declaration of
'XConicalGradient' was here
 } XConicalGradient;
make[3]: *** [cairo-xlib-core-compositor.lo] Error 1
make[3]: Leaving directory

Here cairo's conig.log: http://pastebin.com/76ZBv9rs

I tried to build cairo (for x86_64) and cairo "multilib" (lib32) but the
result is same: the build failed! :(

My cairo (x86_64) build function is this:

build() {
    cd "${srcdir}/${pkgname}-${pkgver}"
    ./configure --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --disable-static \
    --enable-tee \
    --enable-gl \
    --enable-egl \
    --enable-svg \
    --enable-ps \
    --enable-pdf \

and my build function for cairo multilib is at the beginning of this post.

More information about the cairo mailing list