[cairo] Install Help on OSX - Cairo 1.12.16

Ron Abraham ron at rajyaseva.in
Sun May 11 11:14:45 PDT 2014

I need some help installing the current latest cairo source on an OS X 
I am following the basic install steps laid out in the README file.

However ./configure followed by make fails with the following message.

   CCLD   libcairo-gobject.la
libtool: link: warning: `/opt/local/lib/libintl.la' seems to be moved
grep: /opt/local/lib/libiconv.la: No such file or directory
sed: /opt/local/lib/libiconv.la: No such file or directory
libtool: link: `/opt/local/lib/libiconv.la' is not a valid libtool archive
make[4]: *** [libcairo-gobject.la] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1

I tried editing the Makefile (GOBJECT_LIBS) to point to the 
/usr/local/lib directory
where the libintl.la  and libiconv.la files are , but that doesnt seem 
to work and gives me the same error.

I hope this is the right place to ask this question..


No trees were destroyed in the sending of this message;
however, a significant number of electrons were terribly inconvenienced.

More information about the cairo mailing list