[cairo] Fwd: Cairo 1.14 error on OS X 10.10.3 Yosemite

Daven Quinn dev at davenquinn.com
Fri May 8 15:58:07 PDT 2015


I recently upgraded to Cairo 1.14.2 (installed via Homebrew) on my Mac OS X
(latest) system. I am using it via CairoSVG to create PDF graphics. The
upgrade broke the glyph rendering of CairoSVG, resulting in grossly
too-large font glyphs (with the same baseline/spacing as prior, leading to
compressed text). I have tried building from source and relinking. An
example of the output is shown below.

Downgrading to cairo 1.12.16 fixes the issue (see attached), although the
following warning is raised (which does not appear in 1.14):

May  4 18:37:47 Daven-Quinn python2.7[993] <Error>: The function
‘CGFontGetGlyphPaths’ is obsolete and will be removed in an upcoming
update. Unfortunately, this application, or a library it uses, is using
this obsolete function, and is thereby contributing to an overall
degradation of system performance.

Any insights on a possible fix?


note: I tried sending with the below-linked files as attachments, but it
was over the 150 kB (!) limit for message size, so I'm not sure if the
email got through. A graphics library should accept issues in graphical
form! It seems like source-control should be migrated to a newer platform
to ease community contributions.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cairographics.org/archives/cairo/attachments/20150508/68e3203f/attachment.html>

More information about the cairo mailing list