[compiz] gtk-window-decorator - No window borders

Brad Ison ison.brad at gmail.com
Fri Feb 23 17:02:39 PST 2007

Ioannis Nousias wrote:
> Brad Ison wrote:
>> Ioannis Nousias wrote:
>>> is the the "decoration" plugin included in the
>>> "/apps/compiz/general/allscreens/options/active_plugins" key? I have it
>>> third after "gconf" and "inotify" plugin.
>>> Brad Ison wrote:
>>>> Hi,
>>>> I have a strange problem with gtk-window-decorator. I've tried 0.3.6 &
>>>> the latest from git, but with either I don't get any window borders
>>>> when
>>>> running gwd. I hope its not something simple I've missed but I've
>>>> searched around and not found anything. gwd never segfaults or even
>>>> displays any warnings or anything for that matter. It just doesn't draw
>>>> the borders. I've tried every combination of gconf settings (setting
>>>> use_metacity_theme to false etc) and tried changing my metacity theme.
>>>> It still will not draw any borders. I'm running Ubuntu Feisty with
>>>> all the latest updates using an ATI x850 with the free r300 driver and
>>>> Mesa 6.5.2. Compiz itself works alright though I have some weird issues
>>>> with windows not redrawing, but I expect that is due to using a
>>>> somewhat
>>>> experimental video driver. I can't seem to explain why the window
>>>> borders aren't being drawn though. Any ideas?
>>>> _______________________________________________
>>>> compiz mailing list
>>>> compiz at lists.freedesktop.org
>>>> http://lists.freedesktop.org/mailman/listinfo/compiz
>> Please correct me if I'm wrong, but as of 0.3.6 at least, decoration is
>> no longer a plugin to be loaded but a library that gwd is linked to,
>> right?
> mind you I'm not a compiz developer, but I know this:
> The libdecoration is a static library used to design window decorators
> like gwd. This design decision was made to maximize code reuse for any
> window decorator developed for compiz.
> as for the "decoration" plugin it's still there and enables the
> functionality for compiz to support window decorators. So please added
> to you "active_plugins" list :-D

No decoration plugin is installed in $prefix/lib/compiz/ just the
libdecoration libraries are installed into $prefix/lib/. If I do add
decoration to active_plugins compiz won't find it and will remove it
from the list. When I first saw this happening I too thought this was
the problem. So, I went into $prefix/lib/compiz/ and copied the
libdecoration files installed to $prefix/lib/ into the compiz directory
as if they were a plugin. But, when compiz goes to load the decoration
plugin then it complains about not being able to lookup
getCompPluginInfo in libdecoration.so - I see the getCompPluginInfo
function in decoration.c though. So at this point I'm not sure what to

As for xorg 7.2, as Gerd mentioned in another reply that using 7.1 may
be a problem, it hit the Feisty repos today and I am using it. Though I
don't know if all the relevant proto / driver packages are updated yet.

More information about the compiz mailing list