Compiling dbus 0.21 errors

Peter sw98234 at
Sun May 2 23:24:45 EST 2004

Kernel 2.6.5
Slackware 9.1
Python -V: 2.3.1

I intend to use this in order to compile Rox-Session.

I tried CVS-ing the latest 5/2/04 and received the following.

Making all in mono
make[2]: Entering directory `/mnt/src/rox/dbus/dbus/mono'
mcs  --unsafe --target exe -L . -r dbus-sharp.dll -r gtk-sharp.dll -o
test-dbus-sharp.exe Test.cs
error CS0006: Cannot find assembly `gtk-sharp.dll'

Compilation failed: 1 error(s), 0 warnings
make[2]: *** [test-dbus-sharp.exe] Error 1
make[2]: Leaving directory `/mnt/src/rox/dbus/dbus/mono'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/src/rox/dbus/dbus'
make: *** [all] Error 2

I tried to make gtk-sharp.dll directly, but there was no rule.
I downloaded the 0.21 tarball and received the following error:

Making all in python
Traceback (most recent call last):
  File "/usr/bin/pyrexc", line 8, in ?
    main(command_line = 1)
  File "/usr/lib/python2.3/site-packages/Pyrex/Compiler/", line 270,
in main
    result = context.compile(source, options)
  File "/usr/lib/python2.3/site-packages/Pyrex/Compiler/", line 174,
in compile
    tree = self.parse(source, scope.type_names, pxd = 0)
  File "/usr/lib/python2.3/site-packages/Pyrex/Compiler/", line 137,
in parse
    type_names = type_names, context = self)
  File "/usr/lib/python2.3/site-packages/Pyrex/Compiler/", line
175, in __init__
    Scanner.__init__(self, get_lexicon(), file, filename)
  File "/usr/lib/python2.3/site-packages/Pyrex/Compiler/", line
127, in get_lexicon
  File "/usr/lib/python2.3/site-packages/Pyrex/Compiler/", line
93, in try_to_unpickle_lexicon
    lexicon = pickle.load(f)
ImportError: No module named Plex.Lexicons
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../glib -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/python2.3
-DDBUS_API_SUBJECT_TO_CHANGE=1 -g -O2 -Wall -Wchar-subscripts
-Wmissing-declarations -Wmissing-prototypes -Wnested-externs
-Wpointer-arith -Wcast-align -Wsign-compare -MT dbus_bindings.lo -MD -MP
-MF .deps/dbus_bindings.Tpo -c ./dbus_bindings.c  -fPIC -DPIC
-o .libs/dbus_bindings.o
gcc: ./dbus_bindings.c: No such file or directory
gcc: no input files
make[2]: *** [dbus_bindings.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

In both cases, I used the default ./configure switches but added

Thanks for any suggestions.

More information about the dbus mailing list